Page MenuHome

Setting Output Quality to Lossless when exporting FFmpeg video only exports black frames
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10
Graphics card: RTX 2080 Ti

Blender Version
Broken: 2.90.0
Worked: Does not work in 2.83 either based on the versions I tried.

Short description of error
When exporting FFmpeg video with video codec H.264, output set to 'Lossless', it exports a file with only black frames. MPEG-4 and Quicktime both have the same result. Only tested those two containers, and only 'output quality lossless' seemed to create the issue. Every other output quality appears fine. Cycles and Eevee both appear to have this issue.

Exact steps for others to reproduce the error

File attached,

, but it's just a variation of normal startup file.

  1. Open file and check output properties tab.
  2. Set output path to desktop or wherever.
  3. Look at File Format section under Output.
  4. Render animation using output quality 'Losslesss', check file, see only black frames.
  5. Render animation using output quality 'perceptually lossless', check file, see it works fine.

Event Timeline

Alaska (Alaska) changed the task status from Needs Triage to Needs Information from User.Sep 15 2020, 5:37 AM
Alaska (Alaska) added a subscriber: Alaska (Alaska).

I believe this is a issue with the Windows video player. Opening the exported video in a web browser like Google Chrome or opening the video in Blender shows that it does have frames. I've personally had this issue with Nvidia lossless video recording with Open Broadcasting Studio OBS, so I believe it's a Windows video player issue with lossless video, not a issue with Blender.

Are you able to confirm this?

Ah, crap, Alaska yes you appear to be right. Opening in Blender VSE works fine, I think you're right it's just a windows video player issue. So sorry about that! Should I just delete the task? Or is it good to leave it in case someone googles the same issue? Thanks!

Alaska (Alaska) closed this task as Resolved.Sep 15 2020, 6:19 AM
Alaska (Alaska) claimed this task.

Should I just delete the task? Or is it good to leave it in case someone googles the same issue? Thanks!

I've closed the task for you. It will remain on this website so if someone goes looking for it they will be able to find it.