Page MenuHome

mp4 and mov don't play back at their file frame rate.
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: GTX960

Blender Version
Broken: 2.83.6, 2.90


Worked: NA

Short description of error
Rendering mov/mkv/mp4 at 24fps on 2s - The render makes files that report as being 12 fps .
When imported back into Blender the mkv plays back at it's reported frame rate, but the mov and mp4 play frame for frame (2x speed).

Exact steps for others to reproduce the error
Render mov, mkv and mp4 using step = 2, import the results back into Blender. The resulting playback speed is different. Mov and mp4 don't play back on 2's.

Event Timeline

Alaska (Alaska) closed this task as Invalid.Sep 22 2020, 5:40 AM
Alaska (Alaska) claimed this task.
Alaska (Alaska) added a subscriber: Alaska (Alaska).

Thanks for the report, however I am marking this report as Invalid as everything is working as intended.
When the step value is set to 2, every second frame is rendered. To maintain the same "timing" this "new animation" and the "original" animation, the framerate is adjusted, in this case halved to 12fps. When you play this file back in a video viewer, you will observe a 2 second long 12fps video, as expected.

But when you import the video into Blender and play it back, it's only 1 second long. This is because the frame rate in Blender is set to 24fps, meaning the 12fps video plays back at double speed (halving the clip length from 2 seconds to 1 second). To solve this, you must adjust the playback framerate in Blender to match the framerate of your clip or adjust the speed of the playback of the video in the video sequence editor.

Thanks for having a look at this. Is everything really working as intended when the different file types exhibit different behaviour when playing in Blender?
In our case we prefer the behaviour of the mkv for our current use, but as you point out the design intends the mov/mp4 behaviour to be the default.
Is there any scope to add a playback speed setting which could initially be set from the file, but also can be set to another FPS by the user?

Sorry, I seemed to have missed something while triaging your report.

Please make a new report about your issue and hopefully a developer with more knowledge than I do can shed some light on this.