Page MenuHome

Saving image with Alpha (like bloom) not saving correctly
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: Radeon 580 Pro

Blender Version
Broken: Latest 2.91 Alpha @ 23 sept

Short description of error
Since the latest Alpha version of Blender. Eevee can now render bloom on transparency. There was a bug yesterday, that got fixed. Now the Viewport is showing the bloom on transparancy, but when saved to a PNGA, it doenst show the bloom anymore.

Exact steps for others to reproduce the error
Render any image on transparency background, with bloom that covers the transparency. Save as a PNG

See Blender File attached

Event Timeline

Blendfile

Pepper (Sandrino) updated the task description. (Show Details)
Philipp Oeser (lichtwerk) closed this task as Archived.Sep 24 2020, 1:45 PM
Philipp Oeser (lichtwerk) claimed this task.

Thx reporting! I believe this is due to PNGs not suited for encoding emission / occlusion / alpha correctly.
Please follow the lengthy discussion in T52680: Alpha difference Viewport/F12 about occlusion vs emission and PNGs.
(While the Image Editor is now fixed to display this all correctly, the discussion about PNGs still holds true)

Workaround here is to use EXRs.

Afraid we have to close this (feel free to comment again though if issues persist).