Page MenuHome

Blender 2.90.1 crashing when OptiX viewport denoising is enabled
Closed, ResolvedPublic

Description

System Information
Operating system: Win 10 Pro Version 10.0.19041 Build 19041
Graphics card: NVIDIA GeForce GTX 1070
CPU: AMD Ryzen 5 2600
RAM: 16 GB

Blender Version
Broken: 2.90.1, branch: master, commit date: 2020-09-23 06:43, hash: 3e85bb34d0d7, type: Release
Worked: unknown

Short description of error
When I choose Cycles, GPU Compute and the Viewport OptiX Denoiser is activated it crashes when i switch viewport to render. Blender window just abruptly closed. No error window from windows.

Exact steps for others to reproduce the error

  1. Set render engine to "Cycles"
  2. Set device to "GPU Compute"
  3. Set Viewport Denoiser to Automatic" or "OptiX"
  4. Set Viewport Shading to "Rendered"


Related Objects

Event Timeline

Alaska (Alaska) changed the task status from Needs Triage to Needs Information from User.EditedSep 24 2020, 8:12 AM
Alaska (Alaska) added a subscriber: Alaska (Alaska).

Are you able to try clearing your OptiX cache and trying again? This can be done by:

  1. Navigate to %LOCALAPPDATA%\NVIDIA\ (You can also find this folder manually by navigating to C:\Users\YOUR_NAME\AppData\Local\NVIDIA)
  2. Delete the folder called OptixCache

I have the same problem, and I followed in your steps and the problem persists

Sorry, I'm not sure exactly where to go from here. Maybe try a clean install of the latest GPU drivers (even if you're already running the latest drivers). https://www.nvidia.com/download/index.aspx?lang=en-us
Maybe resetting Blender settings then enabling the GPU again will help? To do this select from the top of Blender File -> Defaults -> Load Factory Settings then re-enable the GPU and test again.

For those where these suggestions did not help resolve the crashing, then I would like you to provide crash logs for me. This can be done by:

  1. Navigate to the installation location of Blender.
  2. Open the file blender_debug_log.cmd.
  3. Cause Blender to crash by enabling the OptiX denoiser.
  4. Now a window should pop up containing two files, upload both of them here.
  5. Along with those two files, upload the file blender.crash.txt found in your temp folder (I believe the default location is C:\Users\YOUR_NAME\AppData\Local\Temp)

You may also want to give Blender 2.91 a try, however, expect bugs as it's still in early development: https://builder.blender.org/download/

CC @Patrick Mours (pmoursnv) As you seem to be heavily involved with the development of OptiX for Blender and this issue seems to only affect OptiX. I'm not sure there's much you can do at this current point in time, but I'm tagging you here so you can keep an eye on things.

Alaska (Alaska) renamed this task from Blender Crash Cycles Denoise render view to Blender 2.90.1 crashing when OptiX viewport denoising is enabled.Sep 25 2020, 10:42 AM
Alaska (Alaska) closed this task as Resolved.Sep 25 2020, 10:55 AM
Alaska (Alaska) claimed this task.

Upon further investigation I believe this issue is actually fixed. I will notify the developers for the release of 2.90.2

In Blender 2.91, rB009971ba7adc: Cycles: Separate Embree device for each CPU Device. caused this kind of crashing. It was rolved by rB9f12ea496a3f: Fix T80477: Crash when rendering with Embree but denoising with OptiX, however only the first patch made it into Blender 2.90.1. Applying the second patch to Blender 2.90.1, or using Blender 2.91 fixes the issue.

Ah, we were typing at the same time @Alaska (Alaska) :)

Alaska (Alaska) added a comment.EditedSep 25 2020, 11:03 AM

Ah, we were typing at the same time @Alaska (Alaska) :)

:)

Although, looking back over this report, the issue seems to even occur when GPU compute is enabled. From my understanding rB9f12ea496a3f: Fix T80477: Crash when rendering with Embree but denoising with OptiX is only for CPU rendering... Unless @Sedat Kanatli (Tades) only has their CPU selected in the compute device list... Or this is an entirely different crash.

Dan (SkyDan) removed Alaska (Alaska) as the assignee of this task.Oct 20 2020, 10:37 AM
Dan (SkyDan) added a subscriber: Dan (SkyDan).

Problem also persists with blender 90.1

@Dan (SkyDan) : yep 2.90.1 has this bug, please try a fresh 2.91 build from https://builder.blender.org/download/

Can confirm, it's fixed in the last daily build (2.91.0, alpha, efc2edc47f7a, 10-20-2020). It completes denoising with no crash (CPU as render device).

@Flix Gribv (SuperGlix) Could confirm. It has been fixed in 2.91.0 alpha

2.91.0 doesn't crash but blank render and : OPTIX_ERROR_INVALID_VALUE in optixdenoiserSetModel (denoiser, OPTIX_DENOISER_KIND_HDR,NULL,0) (device_optix.cpp:916)

openimagedenoise and gpu rendering work. (Kubuntu gtx 1070)

@Áron Kovács (aronkvh) Since this is a different error to what was reported in this ticket, please create a new report through Help > Report a Bug in Blender. Open a terminal in Blender's directory and run it with the following command. Try to reproduce the error and attach the log file to your report:

./blender --debug --debug-gpu > ~/blender_debug_output.txt 2>&1

I have same issue, with 2.9 the Renders were rock solid.

Upgraded to 2.9.1 with a new pc build and crash,

It seems to be a cycles issue when denoising is turned on (either automatic or optix)

@John Stopforth (stoppy247) This issue was introduced in 2.90.1 and fixed in 2.91 which is currently in beta.

i was with same error, upgraded to 2.91, works like a charm thanks!

It appears that error is back with 2.93