Page MenuHome

Renders from Cycles coming out "pixelated".
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.4.0-48-generic-x86_64-with-debian-bullseye-sid 64 Bits
Graphics card: GeForce GTX 1050 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 450.66

Blender Version
Broken: version: 2.91.0 Alpha, branch: master, commit date: 2020-09-25 23:18, hash: 83dc97ccc081
Worked: 2.90.1

Any render I make in Cycles comes out "pixelated". If I open the same file and render in Blender 2.90.1 the render comes out perfect without making any change in the settings.
Changing the the render resolution makes the "pixels" bigger aswell.

Open Blender, create any file and render in Cycles.

Blender 2.91 render

Blender 2.90.1 render

Event Timeline

Rodrigo Couto (Calandro) renamed this task from Pixelated renders from Cycles to Renders from Cycles coming out "pixelated"..Sep 26 2020, 1:23 PM

Is this problem really affecting only me? Just downloaded the last branch release and the problem persists. I am surprised no one else have mentioned this problem before or after me.

Same problem occurs in Eevee.

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.Oct 1 2020, 5:49 PM

Can't reproduce this.

Does this happen when you change render size to 100%?
If you save the file is is pixelated when opened in different image viewer?
Can you update GPU drivers?

1 . When I change the size of the render the "pixels" become bigger as well.

  1. Yes, it's the same viewing the image in any other viewer.
  2. Yes, I did update the GPU drivers.

I did not change anything in the file and it renders normally in other blender versions, as 2.90.1.

I tried deleting the blender 2.91 config folder to reset all configs. Nothing changed.

Render size changed to 200%

Sorry, my mistake here. After saving the image it appears normal in other viewers. The problem is only in Blender image viewer (Editor).

It does not affect the view in the compositor backdrop, but if I open the viewer node image from the compositor in the image editor the image appears pixelated again.

This happens even if I use filters in the compositor.

Tried to open images I had already rendered in my computer using the "open image" dialog in the image editor and all images I open look pixelated as well.

So it seems to be a problem in the image editor and not in the render process as I firstly thought.

Richard Antalik (ISS) changed the task status from Needs Information from User to Needs Triage.Oct 6 2020, 10:28 AM

So it seems to be a problem in the image editor and not in the render process as I firstly thought.

@Jeroen Bakker (jbakker) Do you know what could be the problem here? I can't reproduce this, so it may be HW/OS specific

Check in the viewport settings if the GPU textures are resized to lower resolution.


Setting should be switched Off.

Check in the viewport settings if the GPU textures are resized to lower resolution.


Setting should be switched Off.

Yes, it changed everything... BUT, limiting the size of the textures have great effect on how much GPU memory blender uses to show them on the viewport and how complex in terms of textures i can make my scene without overcharging my graphic card, so it seems a bit counterproductive to be forced to disable it because of a behavior that wasn't present in earlier Blender versions.

Also, i cannot understand why a texture setting affects the Image Editor itself.

So does that mean that from now on I will be unable to lower the texture resolutions presented on the viewport? Or maybe I understood the importance of reducing the texture resolutions in the wrong way since the first moment. I am really not sure.

The old image editor used to render pixel for pixel the image what was slow. The new image editor uses opengl textures for rendering. This makes the image editor follow the GL Texture Limit.

If we would have the image in the image editor ignore this setting the GPU could have multiple versions of the texture what would still stress a GPU or the GPU needs to continuously switch texture caches what would stress the PCI bus. Both might limit the use of the GL Texture Limit

T80113: Support Huge Image Sizes in image/uv editor

Richard Antalik (ISS) closed this task as Invalid.Oct 6 2020, 3:49 PM
Richard Antalik (ISS) claimed this task.

Thanks @Jeroen Bakker (jbakker) for explanation.

Since this is working as expected, I will close this report.

Render results definitely should not be affected by this limit, and I would argue no image displayed in the image editor should be either. This is really a 3D viewport feature.

I think it would be reasonable if using the image in the image editor would replace any lower resolution texture for both the image editor and 3D viewport.

Jeroen Bakker (jbakker) reopened this task as Confirmed.Oct 6 2020, 4:01 PM
Jeroen Bakker (jbakker) claimed this task.

Did you guys have noticed that the texture size limit also affects EEVEE renders as well? And in the case of the EEVEE renders the problem is also present in the output file.
I was rendering a video with EEVEE and turned the texture size limit on and the final video was really terrible.

Clément Foucault (fclem) triaged this task as High priority.Feb 1 2021, 3:55 PM

Could the Image Editor maybe be reworked to use Texture Tiles instead ? This wouldnt save on Memory overall but make the use of HW acceleration possible and the tile buffers could also be used in a GL/Shading Compositor Pipeline. So the Limit would limit the Tilesize which either could be fully kept in vram or swapped out on demand to rambuffers - basically utilize texture async streaming.