Page MenuHome

Negative frames not being played in current project
Closed, ArchivedPublic

Description

System Information
Operating system: Darwin-19.3.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 580 OpenGL Engine ATI Technologies Inc. 4.1 ATI-3.5.5

Blender Version
Broken: version: 2.91.0 Alpha, branch: master, commit date: 2020-09-26 20:04, hash: rB8c81b3fb8b9c

Short description of error
Negative frames don't play back in my .blend file (although playback/rendering range and 'Allow Negative Frames' both seem to be set correctly.

Exact steps for others to reproduce the error

  • Open attached .blend
  • Ensure that 'Allow Negative Frames' is ticked in Preferences > Animation
  • Try to play the timeline starting from a negative frame
  • Playhead skips to frame 0 and plays from there instead

Notes

  • New scenes created in this same project have the same problem.
  • If i create a new .blend i don't get this problem in the default scene. But if i append the problem scene into the new project, that scene exhibits the same problem (trying to find a way to salvage the project I'm working on)

Event Timeline

Hm, how did you even set the "start frame -100"? I can't do that...
It also skips to frame 0 when I test your blend.
Tested with Blender 2.90.1

yes, i think that's another bug (that you can't set negative frames via the usual number fields)

  1. Move playhead to negative frame
  2. Timeline view > Playback > "Set Start Frame" button

In rBa4f8b2ad7653 you could set negative frame range and play it back, just enable "allow negative frames" in user preferences.

Now with rB4bb15c8eecbf it doesn't work so this is very recent change. Perhaps intentional checking...

Richard Antalik (ISS) closed this task as Archived.Oct 7 2020, 1:38 PM
Richard Antalik (ISS) claimed this task.

So the bug with this file is, that it has AV sync enabled - Scene audio begins on frame 0 so this will force playhead to jump there. Therefore this is not a bug.

The recent change I talked about is intentional, see rBca38bce46aa2, though it has some negative implications IMO. Not a bug as well though.

Philipp Oeser (lichtwerk) reopened this task as Needs Information from User.Oct 7 2020, 1:46 PM

Thats because of rBca38bce46aa2: Fix T81380: Playback set start/endframe operators can set negative.
This ensured that no negative frames can be set for the rendering range.

To playback negative frames you need to

  • [1] enable Allow Negative Frames
  • [2] use the Preview Range

Timeline view > Playback > "Set Start Frame" button will work then.

I know it is a bit of a convoluted workflow, but having negative frames in the rendering range is also no good...
Does this work for you?

More than a week without reply or activity.
Due to the policy of the tracker closing for until required info/data are provided.

If the problem persists please open a new report with the required information.

sorry for overlooking the request for more information.

my case was: i wanted to retime a scene with existing animation of different kinds (grease pencil, parameter keyframes). i needed to add extra time to the start of the animation. i was reluctant to try to shift all animation forwards in time because i thought i might miss something and mess up the scene. if it was possible to edit and render negative frames, this would have been a 'safer' way to get the extra time i wanted.

i understand that this isn't an option technically, leaving it as invalid is fine.