Page MenuHome

clicking the "report a bug" button inside blender opens a new browser instance and not just a tab
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.4.0-48-generic-x86_64-with-debian-bullseye-sid 64 Bits
Graphics card: GeForce GTX 1070 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 450.66

Blender Version
Broken: version: 2.90.1, branch: master, commit date: 2020-09-23 06:43, hash: rB3e85bb34d0d7
Worked: 2.83 maybe

Short description of error
clicking the "report a bug" button inside blender opens a new browser instance and not just a tab with firefox as default browser. It opened just a tab before. Not that big of a problem, but when closing the normal browsing browser with lots of tabs open and forgetting that the "report a bug" instance is still open this is the last open window and thus remember to open the browser like this and all other open tabs are gone. Sometimes not that bad to get rid of thousands of tabs but mostly unwanted behaviour.

Exact steps for others to reproduce the error
click the "report a bug" button inside blender

Event Timeline

tt (ttt) created this task.Oct 2 2020, 1:12 PM
tt (ttt) updated the task description. (Show Details)
Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Oct 7 2020, 2:23 PM

Cannot reproduce here.

Firefox 80.0.1 for Fedora

Also I dont see codechanges that might have caused this.
Blender just does webbrowser.open https://docs.python.org/3/library/webbrowser.html#webbrowser.open without additional arguments, so the default is to "open in the same browser window if possible"

What happens if you just do this:

import webbrowser
webbrowser.open("https://docs.blender.org/manual/en/")

Does this also open a new window?

I tried the "report a bug" button again, and it opened a new window.

Then I pasted that text into a new text file and let blender run it.

This opens a new tab. Afterwards clicking the "report a bug" button opens in a new tab, this has fixed it.

Ankit Meel (ankitm) closed this task as Resolved.Oct 18 2020, 10:10 PM
Ankit Meel (ankitm) claimed this task.

Afterwards clicking the "report a bug" button opens in a new tab, this has fixed it.