Page MenuHome

Out of Nowhere Viewport Bug in 2.90.1
Closed, InvalidPublic

Description

System Information
Operating system: Win 10
Graphics card: NVIDIA GeForce 940MX

Blender Version
Broken: 2.90.1

Short description of error

I was simply Modelling this Chair, and while placing screws on the Seatplate suddenly all of the Surfaces glitched out in the Viewport. Everything looks normal if you snap the view to the X,Y,Z-Axis, but as soon as you move the view it all freaks out again. And this is what all of my Projects look like now, so its not specific to the model, but something happened to the viewport itself.


Event Timeline

Try adjust the "Clip Start" option in your viewport there (upper right in your video) to something reasonable like 0.01 m

Alaska (Alaska) closed this task as Invalid.Oct 17 2020, 5:21 AM
Alaska (Alaska) claimed this task.
Alaska (Alaska) added a subscriber: Alaska (Alaska).

Marking this report as invalid as the issue is caused by the user setting a small clip start value. Like @Roger B (rboxman) said, try increasing it to a value like 0.01. The option to change the clip start can be found here:

If you believe you have found a bug, please open a new bug report. The artifacts caused by a low clip start value is not considered a bug. It is simply a limitation of the precision of computer graphics. Precision could be increased and as a result smaller and smaller clip start values could be used without artifacts, but generally as precision is increased, performance is decreased.