Page MenuHome

The new Nvidia Ampere card don't work under optix render mode
Closed, ArchivedPublic

Description

System Information
Operating system: windows 10 1903
Graphics card: Nvidia RTX 3090

Blender Version
Broken: 2.90.1

The new Nvidia Ampere cards can work under CUDA mode. Supported and experimental feature set all works fine. But when switched to optix mode, firing IPR or rendering will cause blender not responding.
This test is done by two of my friends who got colorful RTX 3090 ad oc ver. Both of them have the same issue.

Exact steps for others to reproduce the error
Use optix mode to render with Ampere graphic cards.

Event Timeline

NXSK (NXSK) added a subscriber: NXSK (NXSK).
NXSK (NXSK) removed a subscriber: NXSK (NXSK).

Try to run blender_debug_log.cmd that is included in the download.
After Blender closes, the logs will be in a text file which can be attached here.
Most likely it will contain more information about the error.

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from Developers.Nov 3 2020, 12:07 PM

@Patrick Mours (pmoursnv) : cannot test, but I have seen some reports for the new cards [will try to gather them]. Does this ring a bell?

@NXSK (NXSK) : which driver version are you using? Also: could you test fresh builds from https://builder.blender.org/download/?

I'm not aware of any known issues with Blender on Ampere, I have a RTX 3090 rendering both with CUDA and with OptiX without problems (latest drivers). This needs more info.

Philipp Oeser (lichtwerk) changed the task status from Needs Information from Developers to Needs Information from User.Nov 3 2020, 1:06 PM

Thx for the info @Patrick Mours (pmoursnv) !

My best guess with the limited information provided is that you are not waiting long enough and misinterpreting the time it takes for OptiX kernels to compile as Blender not responding indefinetly (this can take a couple of minutes and will say as much in the status message).

Philipp Oeser (lichtwerk) closed this task as Archived.Nov 18 2020, 5:57 PM
Philipp Oeser (lichtwerk) claimed this task.

No activity for more than a week. As per the tracker policy we assume the issue is gone and can be closed.

Thanks again for the report. If the problem persists please open a new report with the required information.