Page MenuHome

Blender crashes after trying to use the smear brush while Dyntopo is enabled
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 452.06

Blender Version
Broken: version: 2.91.0 Alpha, branch: master, commit date: 2020-10-20 21:07, hash: rB7167a57197e9
Worked: (newest version of Blender that worked as expected)

Short description of error
Blender crashes after trying to use the Smear brush while Dyntopo is enabled

Exact steps for others to reproduce the error

  1. enable experimental features
  2. enable dyntopo
  3. select the smear brush
  4. click on the mesh with the selected brush

Event Timeline


I'm assuming this string: (7167a57197e9) appended to the folder name is the build number. Folder/zipped archive name is "blender-2.91.0-7167a57197e9-windows64"

I've tried as well. Same result.
Tried with cube and switching to Sculpt mode, turned on Dyntopo, select smear, click on mesh and crash.
Start new sculpt file, only turned on experimental "Sculpt Vertex Colours" and "Tools with Missing Icons", choose either the paint or the smear brushes, click on mesh and it crashes.

Looks like paint and smear tools are for vertex colours?
No idea if I'm missing something or not.

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.Oct 22 2020, 2:50 PM
Philipp Oeser (lichtwerk) changed the subtype of this task from "Report" to "Bug".