Page MenuHome

Short NLA strips trim/elide action name unnecessarily
Closed, ArchivedPublic

Description

System Information
Operating system: Linux 5.9.1-arch1-1
Graphics card: NVidia GTX 970

Blender Version
Broken: Blender 2.90.1 build hash: 3e85bb34d0d7
Worked: ?

Short description of error

The name label on NLA strips is trimmed to the length of the strip, making it difficult to read the names on short strips.
I often create 1-frame strips for character poses in game development, using the godot-blender-exporter.
It is difficult to tell which is which in the NLA strip.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

  1. Create an action with a name that at least a few letters long
  2. Add a keyframe at time 0
  3. Stash the animation
  4. View the NLA strip

Event Timeline

Richard Antalik (ISS) closed this task as Archived.Oct 29 2020, 12:04 PM
Richard Antalik (ISS) claimed this task.

I don't have much experience in this area and I am not familiar with your workflow (why are you stashing one keyframe animation). But as far as I can see this is not a bug.

Thanks for the report, but the issue reported here is a request for modified/improved behavior and not a bug in current behavior. Closing as this bug tracker is only for bugs and errors.
For user requests and feedback, please use other channels: https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests

For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug