Page MenuHome

Better error handling of unsupported node group inputs
Closed, ResolvedPublicTO DO

Description

Right now if you connect a geometry input in the modifier stack you get a warning in the UI:

Event Timeline

Dalai Felinto (dfelinto) changed the task status from Needs Triage to Confirmed.Nov 5 2020, 6:39 PM
Dalai Felinto (dfelinto) created this task.

Done in rB1ddd71780365: Geometry Nodes: Improve error messages for property mismatches.

The types of errors it checks for should be clear from the strings in that commit.

If I connect a vector3 (e.g., Object Info -> Location) in the group output it throws an error regarding "The node group must have a single geometry output".

I don't think we should throw any error re: output nodes, unless there is NONE Geometry output. Since users can re-use the nodes as either groups or modifiers I don't think they need to be warned about the output.

Suggestion of error when there is no "Geometry Output" socket: "The node group must one geometry output".

Dalai Felinto (dfelinto) closed this task as Resolved.Nov 30 2020, 9:28 AM