Page MenuHome

Camera transformations are not undoable when camera is locked to view
Closed, ArchivedPublic

Description

Hi,
this is not really a bug, rather an oversight, but certainly something to be corrected.
As the title said, when you link a camera to the view and you change the view, applying transformation to the camera, these transformation are not undoable.
This can be a problem when you want to correct an accidentally moved camera (some camera has to be extremely precisely placed).
Also if this kind of undo worked it could be used as easy undo for view change ... there is a lot of claims about the missing of undo for view change, being able to undo 'locked view camera' transformations could be an elegant solution to solve these two issues.
Thank you for reading.
Regards.
Pascal

win 10, hd620
Blender version 2.9 and later

Event Timeline

Robert Guetzkow (rjg) closed this task as Archived.Nov 25 2020, 12:19 PM

I can't reproduce this in 2.92, 2.91 and 2.83.9. All of them allow to undo the changes made to the camera position when Sidebar > View > Lock Camera to View is used.

Could you please create a new report through Help > Report a Bug in Blender and follow the submission template. Please provide system information (operating system, GPU, driver version), affected Blender version, previous Blender version that worked properly, a short and precise description of the issue, step by step instructions to reproduce it and, if relevant, a minimal .blend file that showcases the problem.