Page MenuHome

Potential candidates for corrective releases
Closed, ResolvedPublicTO DO

Description

NOTE: Checked items have already been merged into blender-v2.91-release branch. When adding new items make sure it isn't checked so we know what still needs to be done

List with fixes that could be in 2.91.1

Fixes that could be in 2.91.2

Fixes that could be in 2.91.3

Related Objects

Mentioned In
T86163: Timeline dont show keyframes from Geometrie Nodes
T83347: Smart UV Project crashes Blender 2.91
T83352: In "UV Editor", the movement of UV objects in pixels of an open texture map stopped working when using the [g]+[x/y] keyboard shortcuts (Blender 2.91)
T83296: 2.91 regression: Changing a node's color wheel, color ramp stops, or curves no longer pushes UNDO to the stack.
Mentioned Here
T85958: Potential candidates for corrective releases
rB419c67c8515b: Fix error in recent commit
rBacc662ea5a77: Revert "Fix T83092: Direction of rotation with View orientation changed in 2.91"
rB216ebe0b7392: Fix T83092: Direction of rotation with View orientation changed in 2.91
rBe9cd3d50a795: Fix T84988: Armature symmetries crashes with action constraint
T83027: The active state of collection Incorrect
rBe25f7e33ff4f: Fix T84568: UV loop selection marks edges sharp
rB55c56f1ffb6c: Fix T79356: Improved icons for MSIX builds
rBffb6648a970e: Fix T83625: Shading attribute names cause compilation error.
rBc716b9862aa2: Fix: Update normals when switching scene quality
rBabbc43e4e419: Fix T84397: Creating and removing many objects very quickly causes a crash
rB78011d712dc3: Fix T79356: Improved icons for MSIX builds
rBA8ca823306957: Archipack bugfix: manipulators auto hide
rB5d9919988009: Fix T83084: Smart UV Project inverts the resulting UVs
rBd11a87b88c4d: DrawManager: High quality normals for non meshes
rBa3fcbb54f4b0: GPU: Add HQ normals workaround.
rBcb2517016ba1: GPU: Enable HQ normal work around for AMD Polaris
rB9fb32b2b2921: Fix T84459: Wireframe not displaying with AMD GPU
rB4c44a5309cfa: Fix T84459: Face normals not displaying (AMD GPU)
rB08e44b5e3ebb: Fix Increment Snapping Without Constraints in Non-Axis-Aligned Views
rB2d3f96cace6d: Fix T84453: Crash bezier curves transfrom
rB15bb8f9f936e: Fix file-handle leak when parsing xdg user directories
rBf35a38fba708: Fix BKE_blender_atexit_unregister error removing from linked list
rB967cf303f32f: Fix T83372: Point.select can be True when unselected
rBf0071dfa10b7: Fix T79779: Pick shortest UV face-path ignores sticky setting
rB691c021679f6: Fix T82952: Crash changing mesh data block and switching scenes
rB4b56c1829073: Fix T84426: Limit dissolve ignores selection with custom normals
rB7d25139eaf4a: Fix T82960: Inaccurate selection on collapsed outliner rows
rB8d590e4b8628: Fix T83801: UVEditor translation ignores "Pixel Coordinates" and aspect
rBebd8a703ccb6: Fix T83851: Python: operator macros cause a crash
rBcf2ebaf27c78: Fix T83875: Converting Proxy to override crashes blender.
rBe035d7301c8c: Fix crash sliding effect sequence strips
rB87b19b3aba0c: Fix: BLI_getenv returns ascii not UTF8 on windows
rB2b9eb5eee58a: Fix T83361: UV Editor does not draw pinned selected UVs as pinned
rB5f1a155a5ef3: Fix T83117: Curve bevel not handle aligned at end-points
rBc2a01a6c118e: Fix T83347: Smart UV project crashes with wire edges
rB3d0b65f89b2d: Fix T83296: Unknown actions no longer perform an undo push
rBd1cedf53faaf: Revert "Fix T78823: Slash in custom property name does not work"
T83654: align to transform orientation does not work
rB20f8130d6f90: Fix T82777: Some transform modes using incorrect default orientation
rB898231fdbcc3: Fix transform redo panel showing only the first custom orientation
rB97651f428b6a: Fix T83050: Crash dragging shared collection to master collection
T83050: Dragging a sub-collection out of a scene-linked collection into the "Scene Collection" crashes reliably
rB561d9169fea7: Fix T83280: Crash when deleting hair collision collection.
rBb9eb59213329: Fix T83460: Regression in snap for measure tool
rBf3b08af24c9f: Fix T83352: Move with constraint showing an incorrect value in the header
rBc576d65c2f96: Fix T83161: Crash when moving ruler endpoints and opening or closing the…
rB5c01ecd2bf5d: Fix T82516: Cycles crash updateding animated volumes after NanoVDB
rB84451f89f5c1: Fix T83300: constant scene refreshing in Cycles with empty volumes
rB44f5d99cbf87: Fix T83020: Transform: AutoConstraint being confirmed without releasing the MMB
rBf9e994d0f463: Fix T83092: Direction of rotation with View orientation changed in 2.91
rBe4e7dfc1d8c0: Fix transform snap mixed with incremental

Event Timeline

There are a very large number of changes, so older changes are hidden. Show Older Changes

I am surprised that release 2.91 apparently does not have rB20f8130d6f905321059200756d18e9fffab60b7f (resulting in T83654)
That is a relatively old commit.

In that case, it would be good to check and backport rB20f8130d6f905321059200756d18e9fffab60b7f, rB898231fdbcc34785fefa2030bf9c17dbdedfb63f

I am surprised that release 2.91 apparently does not have rB20f8130d6f905321059200756d18e9fffab60b7f (resulting in T83654)
That is a relatively old commit.

In that case, it would be good to check and backport rB20f8130d6f905321059200756d18e9fffab60b7f, rB898231fdbcc34785fefa2030bf9c17dbdedfb63f

it's developer's responsibility to commit their fix in release branch if/when they think it is safe enough to do so, at least in bcon3 (in bcon4 all commits to release branch must be reviewed and approved by a core team member first).

But we do not do cherry-picking from master into release branch typically. See https://wiki.blender.org/wiki/Process/Release_Cycle

I would like to propose rB87b19b3aba0c: Fix: BLI_getenv returns ascii not UTF8 on windows being back ported because otherwise Cycles is broken for users with special characters in their path to the BLENDER_USER_CONFIG.

How is it that the versioning has switched directly to 2.91.2? This version numbering is both in the file names (https://download.blender.org/release/Blender2.91/) and in Blender itself (as shown in the splash screen). Probably, this was intentional but, just in case, I let you notice it. Thanks.

@Leroy (Leroy) This list is for developers to include commits. Not to raise the awareness or priorities of reported (unfixed) issues.

Jeroen Bakker (jbakker) closed this task as Resolved.Mar 2 2021, 10:43 AM
Jeroen Bakker (jbakker) claimed this task.
Jeroen Bakker (jbakker) updated the task description. (Show Details)

Closing ticket as there won't be any corrective releases anymore for 2.91. See T85958: Potential candidates for corrective releases for 2.92