Page MenuHome

Crash on "ParticleSettings" "Hair" click.
Closed, DuplicatePublic

Description

System Information
2013 Mac Pro
Operating system: Mac OS 10.15.7
Graphics card: AMD FirePro D500 3 GB

Blender Version
Broken: 2.92.0-b379f9348487-, 2.91
Worked: 2.901

With cube selected, create new "Particle Settings" click on "Hair" - Blender quits.

Based on the default startup. File also attached.

File created in 2.901 with hair (rendered as objects) opens and renders fine in 2.91 but cannot be created in 2.91.

Hope this helps. Let me know if you need further information. Thanks!

Further investigation: Seems to be related to displaying the "Hair" paths. If the display tag is turned off "Hair" can be clicked without a crash. If "Render As" is then changed to object the object will be rendered correctly without a crash. Changing "Render As" back to "Path" with the display flag on with crash Blender.

Event Timeline

I cannot reproduce the problem. I suspect that this has something to do with graphics drivers. OpenGL is no longer maintained by MacOS.

It's working fine here on 2.93 Alpha Master Build running in Ubuntu.

I am also having this issue, but it seems to be Mac only. Default cube, add particle system, change to hair, crash. Every time.

Blender 2.93 Alpha, MacBook Pro (Retina, 15-inch, Mid 2015).

Seems to be a repeat of https://developer.blender.org/T75832

Working fine on an older MacBook Pro 13" with just an Intel HD 4000, running on macOS 10.15.7, as mentioned in https://developer.blender.org/T75832