Page MenuHome

Blender temporarly freezes when using loop cut on default cube
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-5.6.17-050617-generic-x86_64-with-debian-buster-sid 64 Bits (Ubuntu Budgie 18.04 LTS)
Graphics card: GeForce GT 650M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 418.152.00

Blender Version
Broken: version: 2.91.0, branch: master, commit date: 2020-11-25 08:34, hash: rB0f45cab862b8
Tested also on
Broken: version: 2.92.0 Alpha, branch: master, commit date: 2021-01-02 22:51, hash: rBc7e92e379d62

Short description of error
I am learning Blender, it's awesome! But when I need to use the Loop Cut tool Blender freezes (mouse pointer stops moving). I recorded a video, here is the link: https://www.youtube.com/watch?v=kynO6Xgv1FQ
I recorded the video using my phone, to show that I am moving my mouse, and the mouse pointer freezes.
First I encountered this bug on Blender 2.91, then I checked on the latest alpha, both versions affected.
PS: As I experience and observe this problem more, I am pretty sure that the whole computer freezes. When I copy files in a background the copying process gets a freeze, and I can't ALT+Tab to other programs when Blender gets freeze

Exact steps for others to reproduce the error

  1. Run Blender with the default cube in the scene
  2. Choose Loop Cut tool, mouseover the default cube
  3. Observe freezes

Event Timeline

DoesItBlend updated the task description. (Show Details)Jan 4 2021, 2:55 AM

I have experienced a similar set of performance issues as when using blender on my secondary hard drive. If it's not just the loop cut but a few other tools struggling with this then here is the explanation I found:

Blender will often try to load Python scripts during use (such as some gizmos, tools, ui, etc). If your storage device is slow to seek for files (be that taking a while to spin up or being hammered with other requests) then blender will likely freeze for a bit until your hard drive loads the requested file. Based on your description of what is happening when using the operating system in general it seems like that might be a hardware issue (don't panic: not necessarily health hopefully, just speed). I would recommend testing your setup with a few storage benchmarks and see if you need to upgrade, or just move blender to a more consistent HDD or SSD.

This might not be your issue, but hopefully this helped narrow it down.

If your entire computer freezes this likely means the issue is outside of Blender. This could be caused by a problem with the graphics driver or GPU.

Robert Guetzkow (rjg) closed this task as Archived.EditedJan 4 2021, 1:29 PM

I will have to close the bug report. Unless you can reproduce significant performance regressions between Blender versions or a bug within Blender (not caused by OS, graphics driver or hardware), then there is not much we can do.

We can always reopen reports should new information indicate a bug in Blender.

I am OK with closing, no problem for me.
I managed to resolve this issue, by rolling back my Linux Kernel to the default of the distribution (4.15.0-39-generic).
This is very strange that my computer freezes only in Blender using the Loop Cut tool on the latest Kernel.
On daily basis I use many programs, for example, these are Jetbrains WebStorm, MongoDB, Docker, Apache Server, NodeJS Server, Sublime Text, and similar. I do not experience computer freeze with the above software, just Blender.