Page MenuHome

file problem
Closed, ArchivedPublic

Description

System Information
Operating system:
Graphics card:

Blender Version
Broken: (example: 2.80, edbf15d3c044, master, 2018-11-28, as found on the splash screen)
Worked: (newest version of Blender that worked as expected)

Short description of error
when trying to append a file the file i saved to put on blender does not appear an when i try to append one that does appear it gives me an error saying "'C:\Users\TEMP\Documents\my file\': not a library and i do not know what to do

Exact steps for others to reproduce the error
*file
*append
click on a folder and file does not appear then press append to import it
Based on the default startup or an attached .blend file (as simple as possible).


thank you!

Event Timeline

Kenzie (kenziemac130) changed the task status from Needs Triage to Needs Information from User.Jan 4 2021, 5:33 AM

Hello,
Appending from this file appears to work for me.

i try to append one that does appear it gives me an error saying "'C:\Users\TEMP\Documents\my file\': not a library and i do not know what to do

I would recommend asking for help on a forum before filing a bug report, that way you can fix your issue if it is on your end or have more information to narrow down what the cause might be.

Robert Guetzkow (rjg) closed this task as Archived.EditedJan 5 2021, 2:44 PM

I can't reproduce the issue either. The error message occurs when BLO_library_path_explode(path, libname, &group, &name) in wm_link_append_exec returns false.

I'll have to close this bug report because it is missing:

  • Steps that allow us to reproduce the problem (at least the currently provided ones seem inaccurate)
  • Operating system, GPU and driver version
  • Affected Blender version and previous version that worked properly
  • Project file that (actually) demonstrates the issue

Hence we are currently not able to reproduce the problem with the provided information. Please create a new bug report through Help > Report a Bug in Blender. We expect all bug reports to follow the submission template. Please provide system information (operating system, GPU, graphics driver version), affected Blender version, previous Blender version that worked properly, a short and precise description of the issue, step by step instructions to reproduce it and, if relevant, a minimal .blend file that showcases the problem.

It could be that you manually typed in a path and that was not pointing to a file as C:\Users\TEMP\Documents\my file\ suggests.