Page MenuHome

bezier circle extrusion value is not consistent with actual mesh value
Closed, ArchivedPublic

Description

System Information
Operating system: win 10
Graphics card: Nvidia GTX 670

Blender Version
Broken: 2.91.0
Worked: (newest version of Blender that worked as expected) unable to check at this time

Short description of error
When i input an extrude value in the geometry tab of a Bezier circle, the mesh size value in the 3d viewport is not that value.

Exact steps for others to reproduce the error
Create a Bezier circle of any size , input values in the extrude window of the geometry tab. I do not use bevel objects for this type of work. At first the eight of the curve is doubled, as I can see it extrude from the center. That would make sense if it was indicated that it would do that. I have not seen any indications that the input would be half the output. Maybe a mention in the tooltips would help here. However, after several reformatting of the circle, the output is no longer consistent, especially if you add and remove vertices from the circle to make, as in my case, a conveyor belt. The input I have is 1.05 inches and the mesh is 1.375. inches

Event Timeline

I found the source of the problem, its not a bug, but it did bug the heck out of me. The problem was the vertices' mean radius was set at .664 instead of .5 (i think that would be the default value?) Once the value was reset, the extrusion and viewport values are consistent.

Sorry for the inconvenience.

I'll go ahead and close this report then. Thanks anyway.

The default "bevel depth" value is zero, so I'm not sure what happened for you.

The default mean radius is set to 1, but if you scale the curve and apply the scale, the mean radius stays the same as the previous scale value. I think this behavior is intentional, so the curve has the same depth you see after applying scales, resetting the mean radius to 1 after applying the scale would make it jump back to the global scale which would be inconvenient if you are working with on a very small scale

Robert Guetzkow (rjg) closed this task as Archived.Jan 9 2021, 11:22 AM

I'm closing the ticket since the issue seems to be resolved and this doesn't appear to be a bug.