Page MenuHome

Audio from rendered video files disappears when saved to camera roll on iPhone or uploaded to social media on desktop
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce GTX 1650 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 451.67

Blender Version
Broken: version: 2.91.0, branch: master, commit date: 2020-11-25 08:34, hash: rB0f45cab862b8
Worked: (newest version of Blender that worked as expected)

Short description of error
This is more of an outside blender issue but I believe blender may be causing it. I was only eventually able to upload my video with sound to social media once I uploaded it to Vimeo and downloaded it again (because it created a new version of the video). I can't figure out if there's any output setting I'd have to change to avoid this, but basically I believe the audio encoding in blender is causing this to happen. I wish I could explain better but it's caused me enough stress and wasted time for now. Hope it can be figured out, whether or not it's a global issue or just something I'm personally missing.

Exact steps for others to reproduce the error
I simply render an animation with sound in the sequencer, it comes out as an mp4 working just fine, continues to work fine when uploaded to google drive, then the audio disappears when downloaded to my phone, or when I tweeted the video.

Event Timeline

Robert Guetzkow (rjg) closed this task as Archived.EditedJan 11 2021, 10:17 PM

If it works on Vimeo but not on other platforms, you're likely using an audio codec that is not supported by some of them. I would suggest you try to select a different one.

Unfortunately, I'll have to close the ticket as this is not a bug in Blender. If you do believe that Blender improperly encodes the audio, then we will need a minimal example project that fails to export properly and step by step instructions to reproduce the problem.

If you need help learning or using Blender, please post a question on one of our community websites, for instance Blender's StackExchange, blenderartists.org or the #support channel on Blender chat.

Sigh...I just used the AAC instead of MP3 and it finally worked. Thank you!