Page MenuHome

gITF 2.0 Import error "could not link (...) Master collection overridden"
Closed, ResolvedPublic

Description

System Information
Operating system: Darwin-20.2.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel(R) UHD Graphics 617 Intel Inc. 4.1 INTEL-16.1.7

Blender Version
Broken: version: 2.93.0 Alpha, branch: master, commit date: 2021-01-15 20:23, hash: rBa8436334bd9c
Worked: (newest version of Blender that worked as expected)

Short description of error
Importing the gITF Model throws Error-Popup and cancels import

Exact steps for others to reproduce the error
Get Model of Osiris REx from Nasa's website: https://solarsystem.nasa.gov/resources/2360/osiris-rex-3d-model/

Import gITF 2.0 to a default startup file throws following error message (varying settings on the import dialog seem to be indifferent):

Python: Traceback (most recent call last):
  File "/Applications/Blender.app/Contents/Resources/2.93/scripts/addons/io_scene_gltf2/__init__.py", line 986, in execute
    return self.import_gltf2(context)
  File "/Applications/Blender.app/Contents/Resources/2.93/scripts/addons/io_scene_gltf2/__init__.py", line 1000, in import_gltf2
    if self.unit_import(path, import_settings) == {'FINISHED'}:
  File "/Applications/Blender.app/Contents/Resources/2.93/scripts/addons/io_scene_gltf2/__init__.py", line 1020, in unit_import
    BlenderGlTF.create(gltf_importer)
  File "/Applications/Blender.app/Contents/Resources/2.93/scripts/addons/io_scene_gltf2/blender/imp/gltf2_blender_gltf.py", line 42, in create
    BlenderGlTF._create(gltf)
  File "/Applications/Blender.app/Contents/Resources/2.93/scripts/addons/io_scene_gltf2/blender/imp/gltf2_blender_gltf.py", line 49, in _create
    BlenderScene.create(gltf)
  File "/Applications/Blender.app/Contents/Resources/2.93/scripts/addons/io_scene_gltf2/blender/imp/gltf2_blender_scene.py", line 40, in create
    BlenderNode.create_vnode(gltf, 'root')
  File "/Applications/Blender.app/Contents/Resources/2.93/scripts/addons/io_scene_gltf2/blender/imp/gltf2_blender_node.py", line 51, in create_vnode
    BlenderNode.create_vnode(gltf, child)
  File "/Applications/Blender.app/Contents/Resources/2.93/scripts/addons/io_scene_gltf2/blender/imp/gltf2_blender_node.py", line 38, in create_vnode
    BlenderNode.create_object(gltf, vnode_id)
  File "/Applications/Blender.app/Contents/Resources/2.93/scripts/addons/io_scene_gltf2/blender/imp/gltf2_blender_node.py", line 110, in create_object
    bpy.data.scenes[gltf.blender_scene].collection.objects.link(obj)
RuntimeError: Error: Could not link the object '_root.003' because the collection 'Master Collection' is overridden


location: <unknown location>:-1

Event Timeline

Robert Guetzkow (rjg) closed this task as Resolved.Jan 16 2021, 2:16 PM
Robert Guetzkow (rjg) claimed this task.

This problem was already fixed in master by rB79dd9fedb242c34646df1af951b8d810ec30c787.

Cool thanks!
And sorry for this kind of "dup"