Page MenuHome

Armature bone constraints not working
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-5.4.0-62-generic-x86_64-with-debian-bullseye-sid 64 Bits
Graphics card: AMD VERDE (DRM 2.50.0, 5.4.0-62-generic, LLVM 11.0.0) X.Org 4.5 (Core Profile) Mesa 20.2.6

Blender Version
Broken: version: 2.92.0 Beta, branch: master, commit date: 2021-01-16 19:09, hash: rB6fb7d0f55927
Worked: (newest version of Blender that worked as expected)

Short description of error
create an armature, parented a mesh to the armature. Add object constraint -> armature not constrained

Exact steps for others to reproduce the error
Start with general startup.
Ctrl+a add a armature
Select cube first, then bone. Ctrl+p to parent cube to Bone
Ctrl+tab change to pose mode. Cube follows bone, as it should, in any direction with bone selected and g for grab.
In pose mode, select Object constraint properties
Add Object constraint > Limit Location
Change to Local Space
Check y minimum, change value to -1m
Check y maximum change to 1m
Back in 3D viewport, select bone (already selected), press g to grab, bone and cube move without any constraint
[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

I had a problem with beta Blender2.92.0. One is that the object outline isn't working. The second is that armature Limit Location Constraint for a bone/armature isn't working

From what it looks like in your file you set the modifier on the armature not the bone. The bone will be tinted green when constrained. This is not a bug. Closing.