Page MenuHome

viewport shading options not taking effect until clicking in viewport
Closed, DuplicatePublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce GT 730/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.50

Blender Version
Broken: version: 2.93.0 Alpha, branch: master, commit date: 2021-01-21 00:12, hash: rB41a945d7469f
Worked: not sure, but I think it worked a month ago or so with 2.93 daily

Short description of error and Exact steps for others to reproduce the error
while in viewport looking at cube
I select viewport shading> solid,
then I go to the viewport shading dropdown menu> viewport shading> lighting> studio (or matcap),
when I select one of the options there, studio and matcap changes do not take effect until I click in the viewport,
at which point the changes do take effect,
whereas in recent previous Blender versions I think I could just click on one of the lighting setup orbs
and see the resulting changes in the viewport, without having to exit the lighting orb options and go into
the viewport
I liked being able to just click on an orb and see the changes in the viewport, immediately, trying various orb options until I see a result I like, rather than having to click in the viewport to see a new result, because then I have to navigate back to through shading menu again in order to try various options there, not a problem unless I want to keep trying lots of various options, but if I do want to try lots of various options it's a lot of extra menu navigation, thanks for checking this, maybe its something on my end