Page MenuHome

Random crashes while sculpting in 2.91 (Segmentation Fault)
Closed, ResolvedPublic

Description

System Information
Operating system: Manjaro
Graphics card: AMD Fury X and Firepro w8100

Blender Version
Broken: 2.91.0 & 2.92 beta
Worked: 2.83

Short description of error
Not sure if related but launching blender in terminal I receive the error:

LLVM triggered Diagnostic Handler: Illegal instruction detected: VOP* instruction violates constant bus restriction
renamable $vgpr1 = V_CNDMASK_B32_e32 32768, killed $vgpr2, implicit killed $vcc, implicit $exec
LLVM failed to compile shader
radeonsi: can't compile a main shader part
LLVM triggered Diagnostic Handler: Illegal instruction detected: VOP* instruction violates constant bus restriction
renamable $vgpr3 = V_CNDMASK_B32_e32 32768, killed $vgpr3, implicit killed $vcc, implicit $exec
LLVM failed to compile shader
radeonsi: can't compile a main shader part

Upon sculpting I randomly crash at times. Every time the circle around the cursor disappears as an indicator I'm going to crash. Then I receive Segmentation Fault.

Exact steps for others to reproduce the error
-Create cube
-Sculpt and remesh(repeat)

Event Timeline

Delo Lat (edisto) added a comment.EditedJan 22 2021, 2:11 AM

2.83 seems to work fine. Receive a similar error at start, but it does not appear to crash while sculpting.

LLVM triggered Diagnostic Handler: Illegal instruction detected: VOP* instruction violates constant bus restriction
renamable $vgpr3 = V_CNDMASK_B32_e32 32768, killed $vgpr3, implicit killed $vcc, implicit $exec
LLVM failed to compile shader
radeonsi: can't compile a main shader part
Robert Guetzkow (rjg) changed the task status from Needs Triage to Needs Information from User.EditedJan 22 2021, 3:28 PM

The crash seems unrelated to the shader compilation. We would need precise steps to reproduce the problem in sculpt mode though, otherwise we might not be able to identify the source of the issue.

Please also check if disabling installed add-ons prevents the crash from occurring.

It's quite random and is on anything I sculpt. Creating a simple cube and sculpting with crease brush for a matter of minutes or sometimes 10, it can then crash. I've tried 2.92 beta and experience the same issue with all addons turned off.

Delo Lat (edisto) added a comment.EditedJan 28 2021, 2:13 AM
PID: 7223 (blender)
           UID: 1001 
           GID: 1001 
        Signal: 11 (SEGV)
     Timestamp: Wed 2021-01-27 16:48:20 PST (13min ago)
  Command Line: blender
    Executable: /usr/bin/blender
 Control Group: /user.slice/user-1001.slice/user@1001.service/app.slice/app-gnome-blender-7223.scope
          Unit: user@1001.service
     User Unit: app-gnome-blender-7223.scope
         Slice: user-1001.slice
     Owner UID: 1001 
       Boot ID: *
    Machine ID: *
      Hostname: *
       Storage: /var/lib/systemd/coredump/core.blender.1001.4d910a0f3efd4ff69e80b8b0b91a9148.7223.1611794900000000.zst (inaccessible, truncated)
       Message: Process 7223 (blender) of user 1001 dumped core.
                
                Stack trace of thread 7223:
                #0  0x0000555cb5baf30a do_enhance_details_brush_task_cb_ex (/usr/bin/blender + 0x18f830a)
                
                Stack trace of thread 7247:
                #0  0x00007f42aac0f014 n/a (n/a + 0x0)

warning: Error reading shared library list entry at 0x2d006574656c706d

warning: Error reading shared library list entry at 0x74647370617473
Failed to read a valid object file image from memory.
--Type <RET> for more, q to quit, c to continue without paging--
Core was generated by `blender'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x0000555cb5baf30a in do_enhance_details_brush_task_cb_ex ()

I'm still not able to reproduce the problem on Windows and Linux. It's strange that a crash related to do_enhance_details_brush_task_cb_ex() would happen when using the crease brush as this function is only called by the smooth brush.

Delo Lat (edisto) added a comment.EditedFeb 17 2021, 12:34 AM

I'm still not able to reproduce the problem on Windows and Linux. It's strange that a crash related to do_enhance_details_brush_task_cb_ex() would happen when using the crease brush at this function is only called by the smooth brush.

It could be related to hitting shift and smoothing. I switch between crease and smooth often(by using shift to smooth). Since it is so random, I can't recall particularly if I was sculpting regularly or using shift to smooth. It does not appear to occur in windows, and works fine in 2.83.

@Delo Lat (edisto) We would need exact instructions to reproduce this. Please try to figure out the precise steps that lead to the crash and if Blender does crash upload the crash log that can be found in the /tmp directory.

@Delo Lat (edisto) Were you able to identify the exact steps that lead to the crash?

Delo Lat (edisto) closed this task as Resolved.Mar 11 2021, 12:32 AM
Delo Lat (edisto) claimed this task.

Sorry for the late response, I go back and forth between many jobs. My blender crash log was uploaded in the first message. I had to reinstall manjaro due to an issue with my grub not showing at boot after an update. It appears to no longer crash. Thank you.