Page MenuHome

error : "'utf-8' codec can't decode byte 0xb9 in position 22: invalid start byte"
Closed, ResolvedPublic

Description

system : rtx2070super, 3700x ,8x2 ram.
bug in belnder version : 2.79, 2.8, 2.92
previous success version : 2.79. 2.8

problem : when i use 'add-ons', console say "utf-8' codec can't decode byte 0xb9 in position 22: invalid start byte"

problem file :

Related materials, etc. :

,

Blender's python I downloaded :

I'm really new person to coding. (I don't know where to look at coding..) Sorry, but please explain in detail

Event Timeline

Thank you for your report. As instructed in your previous ticket we need step by step instructions of what you've done that resulted in the described error. For future bug reports, please consult this guide.

This is likely caused by improper UTF-16 handling by Blender on Windows that should be fixed by D9822. However, without having the required information to reproduce the problem I cannot confirm if the patch would fix it.

Robert Guetzkow (rjg) changed the task status from Needs Triage to Needs Information from User.Jan 22 2021, 2:31 PM
This comment was removed by 조현영 (helouu).
This comment was removed by 조현영 (helouu).
조현영 (helouu) added a comment.EditedJan 22 2021, 5:06 PM

System Information
Operating system: Windows-10-home-64bit
nvidia geforce 2070super ver.3.2.0.5.70
ryzen 3700x
16(8x2)GB

Blender Version
Broken: version: 2.80, 2.79, 2.92,
Previous fine ver : all version
branch: master
commit date: 2021-01-22 12:00~now
hash: ?
Worked: (optional)

Short description of error
An error occurred while installing'mod3' for import-export of mhw.
"'utf-8' codec can't decode byte 0xb9 in position 22: invalid start byte"

Exact steps for others to reproduce the error

run blender
click to "edit" -> "preferences" -> "add-on"
installing the 'mod3-mhw~(

)'
(4. If it works normally, there will be'mod3' in import-export.)
[Based on the default startup or an attached .blend file (as simple as possible)]

Blender's pyton that I downloaded :

If you need more information, I will write it in the comments.
However, I am very new to coding. Please explain the solution in detail.

I went into the place you posted on'to mention', but I don't understand. Addresses like source/blendlib/intern aren't in my blender. Also in pythons37 the code is at least the word'define'.

@조현영 (helouu) Those files are the source code of Blender which is compiled into the blender.exe. The patch I mentioned should be included soon and then you'll be able to test one of our daily builds to check if this resolves the problem. Based on the provided information it seems likely, but I haven't had time to test this yet. In order to reproduce the problem I would have to change my localization settings to Korean.

조현영 (helouu) added a comment.EditedJan 23 2021, 3:22 PM

Does that mean that I can download it from Blender's homepage after the error is patched later?
(I'm really new to this, so I have a lot of questions. I'm really sorry.)

Yes, once the patch has landed it will be included in the daily builds of the Blender versions that are currently in development. They can be downloaded from the following page https://builder.blender.org/download/. Please note that these are experimental builds and should not be used for production work.

조현영 (helouu) added a comment.EditedJan 23 2021, 3:41 PM

I understand. Finally, one more question... The file I mentioned,'mhw-mod3~', is specialized for Blender 2.8 ver, so I didn't properly experiment with 2.9. If the 2.92ver.beta, 2.93.ahlpa version does not continuously apply, can you send it me separately as 2.8x version?

And thank you very much for your hard work. The stuffy part got better!!

@조현영 (helouu) The patch is now in the master branch (rB5496d8cd361385268316f91afa150e69b5345ab0) and will be included in the next daily builds of Blender 2.92 and 2.93.

You will have to modify the add-on to work in 2.9x then. There haven't been many API changes in the meantime, so this shouldn't be too complicated. If you need help with this, please either contact the original developer or ask about it on one of our community websites.

Since the fix is in the daily builds: is this issue resolved?

Robert Guetzkow (rjg) closed this task as Resolved.Sat, Feb 20, 11:41 PM
Robert Guetzkow (rjg) claimed this task.

Since the UTF-16 issue has been fixed, it worked in my tests and we haven't received any reports of the contrary in over a week, I'm closing this ticket as resolved.