Page MenuHome

Boolean modifier bug
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: AMD Radeon(TM) Vega 8 Graphics ATI Technologies Inc. 4.5.14736 Core Profile Context 20.9.1 27.20.12029.1000

Blender Version
Broken: version: 2.91.2, branch: master, commit date: 2021-01-19 16:15, hash: rB5be9ef417703
Worked: (newest version of Blender that worked as expected)

Short description of error
boolean modifier difference when applied is removing the edge crease and resetting it completely

Exact steps for others to reproduce the error
add a cube use make 2 adjacent edges edge crease max and add a subsurf modifier
then add a cube after that add a boolean modifer to the subsurfed cube and choose difference and select the new cube
after that apply it and once after it is applied it should have completely removed the edge crease of the mesh with subsurf modifier
sometimes it remove the sharp edges also

Event Timeline

The boolean modifier hasn't preserved creases in earlier versions either. To the best of my knowledge this is a known limitation.

@Howard Trickey (howardt) Correct me if I'm wrong, but this is not a bug?

ok sorry i thought it was a bug

Robert Guetzkow (rjg) closed this task as Archived.Jan 25 2021, 11:26 AM