Page MenuHome

blender 2.91.2 error: EXCEPTION_ACCESS_VIOLATION
Closed, ArchivedPublic

Description

Device name DESKTOP-BBFO6I9
Processor Intel(R) Core(TM) i3-6006U CPU @ 2.00GHz 1.99 GHz
Installed RAM 20.0 GB (19.4 GB usable)
Device ID AD5AF3A9-B4BD-464E-8941-B1792E833903
Product ID 00325-81081-03317-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Short description of error

the black screen come up then its shows error: EXCEPTION_ACCESS_VIOLATION” for a second the blender app turns on then shuts off in a seccond

Exact steps for others to reproduce the error
To me it occurs as soon as the application has started

Event Timeline

I can confirm this bug with

  • the Windows 10 App,
  • the regular installed version 2.91.2 and
  • the latest portable version blender-2.93.0-ded9484925ed-windows64; crash report file:

Output from ProcessExplorer:

Dear @Markus Werle (daixtrose),
So as of now is there a fix, and thanks to you im delighted to know that my device is above the minimal requirements to run the app as i wasnt sure about the sse2 support.
Thanks and Regards,
@shaurya (Xicon)

I am a user like you are, I just wanted to confirm you are not alone and need not waste time to check other versions, since it seems all are affected somehow.

Output from git bash:

~/Downloads/blender-2.93.0-ded9484925ed-windows64
$ ./blender.exe --debug-memory
Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x0000000000000000
Module  :
Thread  : 00001a98
Switching to fully guarded memory allocator.
Writing: C:\Users\werle\AppData\Local\Temp\blender.crash.txt

so as of now i cant use blender right

@shaurya (Xicon) Please open Blender's installation directory and double click on the blender_debug_gpu.cmd. This will start Blender in debug mode and create log files. Try to make Blender crash again. Once it crashes the Windows Explorer should open and show you up to two files, a debug log and the system information. Add them to your bug report by clicking on the upload button as shown in the screenshot below or via drag and drop. Please also upload the crash log located in C:\Users\[your username]\AppData\Local\Temp\[project name].crash.txt (or simply type %TEMP% into the path bar of the Windows Explorer).

@Markus Werle (daixtrose) Your problem looks similar to the T72098 issue. Please keep in mind that just because Blender crashes, it doesn't mean that it's the same issue as other tickets. I would therefore ask you to create your own report.

Please check

  • whether your monitor is connected to the GPU or motherboard
  • if you have multiple monitors
  • what your Windows Graphics settings have configured as the default GPU

You may want to try the workaround explained in T78799 and see if this allows you to start Blender.

Robert Guetzkow (rjg) changed the task status from Needs Triage to Needs Information from User.Jan 25 2021, 11:36 AM

@Robert Guetzkow (rjg) interesting enough I had followed that advice before and it did not work. Now I tried again after another update and I can confirm that attaching the builtin Intel graphics device lets me start the app. Alas, selecting the Nvidia Quadro M1200 leads to the crash.

Of course this is not a solution. 3 Questions:

  • Do you think it is helpful that I report this again providing the graphics device information?
  • I am using latest Windows 10 and latest NVIDIA driver. What am I to do?

Thanks for your help though my problem got fixed when I went back to the setup wizard and clicked on repair turn out some files were missing with the installation

Robert Guetzkow (rjg) closed this task as Archived.Jan 26 2021, 10:12 AM

@shaurya (Xicon) I'm closing the ticket then.

@Markus Werle (daixtrose) As I've said, please create a separate report as your issue has nothing to do with this ticket. Please include the answers to the questions I've posted in your ticket. It may very well be the exact same problem as T72098 in which case the ticket will be merged, but I'll have to check this first.

It's a graphics device problem and I find it odd the software has to crash. I'd prefer a native window start first and allow collecting system info b4 trying to write to null pointers via nvidia drivers.