Page MenuHome

Blender 2.83 crashes opening a file saved in 2.93alpha
Confirmed, NormalPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce RTX 2080 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 461.09

Blender Version
Broken: version: 2.93.0 Alpha, branch: master, commit date: 2021-01-21 00:12, hash: rB41a945d7469f
Worked: (newest version of Blender that worked as expected)

Short description of error
Hi, I saved a project in Blender 2.93alpha (just the default cube). Opening it in Blender 2.83, it crashes immediately. I know that it is an alpha release but test it. Thanx.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Jan 25 2021, 9:38 AM

Cannot reproduce here.

Here is the default cube saved from rBcf6d17a6aa42, this opens fine in 2.83.10

Does this crash for you as well in 2.83?
If not, please post your example file saved from 2.93 that crashes in 2.83.
Please also try with File → Defaults → Load Factory Settings to see if you still can reproduce this issue.

I wonder that only basic file with original cube crashes in 2.83.
If I modify the cube in another object and save it, reopening it in 2.83 it didn't crashes. very very strange...
In attachment the cube realized in 2.93 that crashes 2.93.

The issue is caused by the Asset Browser being visible in your file. I can confirm that loading the attached file in 2.83.10 results in a crash. Removing the area with the Asset Browser allows to open the file properly. Given that Blender is not really forward compatible, I'm not sure if / how new editor types are supposed to be handled that aren't available in past versions @Philipp Oeser (lichtwerk)?

# Blender 2.83.10, Commit date: 2020-12-07 14:09, Hash b439a155442b
File written by newer Blender binary (290.0), expect loss of data!  # Error

# backtrace
./blender(BLI_system_backtrace+0x1d) [0x698a2cd]
./blender() [0xc15b62]
/lib/x86_64-linux-gnu/libc.so.6(+0x46210) [0x7fb722a05210]
./blender(ED_region_exit+0x2c) [0x122676c]
./blender(ED_region_remove+0x14) [0x1226844]
./blender() [0x4c711ef]
./blender(ED_area_do_refresh+0x1b) [0x121d85b]
./blender(wm_event_do_refresh_wm_and_depsgraph+0x6c) [0xec69cc]
./blender(wm_event_do_notifiers+0x472) [0xecd4d2]
./blender(WM_main+0x28) [0xec2d88]
./blender(main+0x311) [0xb4c6a1]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf3) [0x7fb7229e60b3]
./blender() [0xc122dc]
Philipp Oeser (lichtwerk) changed the task status from Needs Information from User to Confirmed.Jan 25 2021, 3:52 PM

@Julian Eisel (Severin): were non existent Editors not replaced with a default one?