Page MenuHome

Crash from Compositor
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.8.0-40-generic-x86_64-with-debian-bullseye-sid 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 460.32.03

Blender Version
Broken: version: 2.93.0 Alpha, branch: master, commit date: 2021-01-27 13:52, hash: rB6f7e2bf170a1
Worked: blender-2.93.0-e41a8bfabe13-linux64 (latest Build Bot)

Short description of error
Blender crashes when "doing stuff" in the Compositor. Sadly I can't describe it much better and I also can't attach a repro blend file (which would basically be empty anyway) because Blender crashes during saving as soon as I have a Compositor node tree in the scene.

Exact steps for others to reproduce the error

  • Open Blender and switch to "Compositing" layout
  • Click on "Use Nodes"
  • SHIFT + CTRL click on the "Render Layers" node to add a Viewer.
  • Click on the "Composite" node and click X to delete it
  • Blender crashes / closes

There are many other ways to crash Blender while clicking in the Compositor but this is one that works 100%
The current build from the Build Bot is fine so the bug must've crept in lately.

Event Timeline

Robert Guetzkow (rjg) changed the task status from Needs Triage to Confirmed.Jan 27 2021, 4:06 PM

That would be caused by the revert of rB0f95f51361d73fbd8ba8d80b3b65da930dcf3b20 by rBcd24712c2c51ab753369f7cae8c43c38115bd59f. The change was reverted because it broke the user interaction as the viewport didn't update properly (see T84717).

I will confirm this ticket for now, but this should be fixed when the patch lands again after the viewport issue has been addressed.

Robert Guetzkow (rjg) closed this task as Resolved.Jan 28 2021, 11:22 AM
Robert Guetzkow (rjg) claimed this task.

Thanks! I can confirm the fix is working for me!