Page MenuHome

Strange grase pencil brush rendering since 2.91 version
Closed, DuplicatePublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 461.40

Blender Version
Broken: version: 2.91.2, branch: master, commit date: 2021-01-19 16:15, hash: rB5be9ef417703
Worked: (newest version of Blender that worked as expected)

Short description of error
I've been using a custom grease pencil brush. When I draw on blender 2.90 in front of a geometry it looks perfectly fine. But if I use it on Blender 2.91 or 2.91 I always get a strange white base color behind each stroke. It looks like if the transparency or the alpha on the brush it's not completely rendered in real time.

Exact steps for others to reproduce the error
I attached a file where you can compare the look on different Blender versions, it consist of several lines drawn on front of a cube, the custom brush I'm using it's also on the scene. It's very noticeable as soon as you continue drawing on that same layer.

Thanks in advance.

Event Timeline

dupoxy added a subscriber: dupoxy.EditedSat, Feb 13, 2:56 PM

I can confirm the strange white base color behind each stroke in front of a geometry in draw mode.
A workaround is to turn off overlays .
A video of a quick test in 2.90, 2.91 and 2.93 Alpha

go inside any mode thats not object mode and deactivate "fade inactive geometry" inside the overlays, this feature was implemented in 2.91 as a sculpting feature but it is enabled by default

go inside any mode thats not object mode and deactivate "fade inactive geometry" inside the overlays, this feature was implemented in 2.91 as a sculpting feature but it is enabled by default

Thank you! This worked. Thank you for your help guys.

Closing since this is not a bug.