Page MenuHome

Adjust Last Operation panel is slow (some Undo/Redo happening?)
Confirmed, NormalPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce GTX 950M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 398.35

Blender Version
Broken: version: 2.92.0 Alpha, branch: master, commit date: 2021-01-07 22:28, hash: rB61f1faac3f21

Short description of error
In scenes with visible or invisible objects with modifiers, the options menu freeze


Exact steps for others to reproduce the error

Windows, 2.92 (can't use 2.93 or higher) can confirm.
For test file in header (the 2MB one), I can't see any problem with 2.92 or 2.90.0. But 2.83.16 I see slowdown.
Test file (the 26MB one) have problem but not easy to catch at first. How I got it to "work":

  1. Open file
  2. Delete visible sphere
  3. Add another UV sphere
  4. Delete it
  5. Add yet another UV sphere
  6. Change anything via last operation menu and see slowdown

For this bug you only need text object with his modifiers. In 2.83.16 you don't need those steps to reproduce, it's always laggy.

Event Timeline

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Needs Information from User.Feb 18 2021, 3:19 PM

I cannot reproduce this with either the latest stable or current development versions of Blender.

Please try the latest daily build: https://builder.blender.org/download/

Go to File → Defaults → Load Factory Settings and then load your file to see if you still can reproduce this issue.

If the problem persists, please give us more clear instructions on how to reproduce it from scratch.

Cannot reproduce here

**System Information**
Operating system: Linux-5.10.12-200.fc33.x86_64-x86_64-with-fedora-33-Thirty_Three 64 Bits
Graphics card: GeForce GTX 970M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 455.45.01
version: 2.93.0 Alpha, branch: master, commit date: 2021-02-07 23:21, hash: `rBeb7d9e2a1bba`

I assume you have checked the lastest builds from https://builder.blender.org/download/?
Please try with File → Defaults → Load Factory Settings to see if you still can reproduce this issue.

Download new 2.93 - same problem. Do you open attach file?
In new scene this problem can't reproduce, but in large or in the scene with Remesh modifier freezes begin
Try in this scene create a sphere and change parameters.

I am seeing the same as @Germano Cavalcante (mano-wii) (no issues afaict)

Test please this file

Philipp Oeser (lichtwerk) changed the task status from Needs Information from User to Needs Triage.Feb 28 2021, 8:44 AM

I can't reproduce the problem with the new file either.
It is possible that an addon is causing this.
Try with the factory settings (File → Defaults → Load Factory Settings)

I can't reproduce the problem with the new file either.
It is possible that an addon is causing this.
Try with the factory settings (File → Defaults → Load Factory Settings)

It's with factory settings!

Try to run blender_debug-gpu.cmd that is included in the download.
Replicate the problem quickly and then close Blender.
After Blender closes, the logs will be in a text file which can be attached here.
Most likely it will contain more information about the error.

It would be good to redo the tests with factory settings.
Some addons interfered with the results.
uvpackmaster2 for example was not un-registered correctly.
DreamUV-master showed some warnings.

It is interesting to note that there is a space between each message of redo_cb: operator redo Add UV Sphere.
The expected would be something like this:

redo_cb: operator redo Add UV Sphere
redo_cb: operator redo Add UV Sphere
redo_cb: operator redo Add UV Sphere
redo_cb: operator redo Add UV Sphere
(...)

Unfortunately I still don't think there is enough to identify the cause of the problem.
Try to run blender_debug_log.cmd, it might show something more informative.

Can't redo on 2.92, 2.93. On 3.0, there's an use after free issue:

Can not reproduce either.

@Philipp Oeser (lichtwerk) , Better we tag this as Unconfirmed because no one is able to replicate the issue so far :)

Windows, 2.92 (can't use 2.93 or higher) can confirm.
For test file in header, I can't see any problem with 2.92 or 2.90.0. But 2.83.16 I see slowdown.
Test file in comments have problem but not easy to catch at first. How I got it to "work":

  1. Open file
  2. Delete visible sphere
  3. Add another UV sphere
  4. Delete it
  5. Add yet another UV sphere
  6. Change anything via last operation menu and see slowdown

For this bug you only need text object with his modifiers. In 2.83.16 you don't need those steps to reproduce, it's always laggy.

Windows, 2.92 (can't use 2.93 or higher) can confirm.
For test file in header, I can't see any problem with 2.92 or 2.90.0. But 2.83.16 I see slowdown.
Test file in comments have problem but not easy to catch at first. How I got it to "work":

  1. Open file
  2. Delete visible sphere
  3. Add another UV sphere
  4. Delete it
  5. Add yet another UV sphere
  6. Change anything via last operation menu and see slowdown

For this bug you only need text object with his modifiers. In 2.83.16 you don't need those steps to reproduce, it's always laggy.

I can repro with these steps.

Philipp Oeser (lichtwerk) added a project: Restricted Project.Jun 25 2021, 12:20 PM
Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.Jun 25 2021, 12:23 PM
Philipp Oeser (lichtwerk) updated the task description. (Show Details)

Though not really doing anything outside the Adjust Last operation panel in between, T78171: Adjust Last Operation: Other changes outside that panel are reverted back automatically might be related in a way.

Philipp Oeser (lichtwerk) renamed this task from Freeze option menu to Adjust Last Operation panel is slow (some Undo/Redo happening?).Jun 25 2021, 2:08 PM