Page MenuHome

Any addon installation from zip will fail in Blender 2.93 (using Python 3.9.1)
Closed, DuplicatePublic

Description

System Information
Operating system: Darwin-20.3.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel(R) Iris(TM) Plus Graphics 640 Intel Inc. 4.1 INTEL-16.1.10

Blender Version
Broken: version: 2.93.0 Alpha, branch: master, commit date: 2021-02-18 23:56, hash: rB4604350eefab
Worked: pre-python3.9.1 builds

Short description of error
Attempting to install an addon from a zip file will fail with the following error:

Python: Traceback (most recent call last):
  File "/Applications/Blender.app/Contents/Resources/2.93/scripts/startup/bl_operators/userpref.py", line 609, in execute
    import zipfile
  File "/Applications/Blender.app/Contents/Resources/2.93/python/lib/python3.9/zipfile.py", line 6, in <module>
    import binascii
ImportError: dlopen(/Applications/Blender.app/Contents/Resources/2.93/python/lib/python3.9/lib-dynload/binascii.cpython-39-darwin.so, 2): Library not   loaded: libz.1.dylib
  Referenced from: /Applications/Blender.app/Contents/Resources/2.93/python/lib/python3.9/lib-dynload/binascii.cpython-39-darwin.so
  Reason: unsafe use of relative rpath libz.1.dylib in /Applications/Blender.app/Contents/Resources/2.93/python/lib/python3.9/lib-dynload/binascii.cpython-39-darwin.so with restricted binary

Simple demo addon, that does nothing for testing;

Exact steps for others to reproduce the error

  • install this or any other addon on recent 2.93 builds on MacOS