Page MenuHome

Full copy of scene doesn't behave as expected with shaders (maybe among other things)
Closed, InvalidPublic

Description

System Information
Operating system: MacOS 11.2 & WIN10
Graphics card: AMD Radeon Pro 5500M 8 GB & Quadro 1100

Blender Version
Broken: 2.92 & 2.93
Worked: 2.83.10

Short description of error
Doing a Full Copy of a scene


And changing an object's shader (for example) in the new scene, doesn't behave as expected (the shader is changed in both the original and the copied scene).
Exact steps for others to reproduce the error
. Use startup scene.
. Go in Shading Layout.
. Do a full copy of the scene.
. Change Cube object shader to Emission Shader.
. Switch back to original Scene. The Shader has changed there too!
In 2.92 & 2.93:

How it should behave (2.83):

Thanks!!

Event Timeline

Piotr Nikov (piotrnikov) renamed this task from Full copy of scene doesn't act as expected with shaders (maybe among other things) to Full copy of scene doesn't behave as expected with shaders (maybe among other things) .Tue, Feb 23, 12:02 PM
Piotr Nikov (piotrnikov) created this task.
Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Tue, Feb 23, 4:42 PM

Do you have this turned OFF (seems like this is now respected -- will dig up which commit did this)?

Do you have this turned OFF (seems like this is now respected -- will dig up which commit did this)?

AAhhhhh! Yes it was off (like in 2.83) and turning it ON makes everything work as expected!
Thanks so much @Philipp Oeser (lichtwerk)!