Page MenuHome

Mac: Copy & Paste in Outliner copies unselected second object
Closed, ArchivedPublic

Description

System Information
MacBook Pro (Retina, 13-inch, Mid 2014)

Operating system: macOS 10.14.6
Graphics card:

Blender Version
Broken: Version 2.93.0 (2.93.0 2021-02-25) & Version 2.92.0 (2.92.0 2021-02-25)
Worked: ??

Short description of error
When I select and copy one object in Outliner, it copies a second object....see video.

Exact steps for others to reproduce the error

  1. Open attached .blend file.
  2. In the Outliner, right-click Cube then Copy and Paste.
  3. The plane is also duplicated.

Notice that this does not happen when using "Duplicate" with "Shift+D".

Event Timeline

it's the mirror modifier that's causing the problem...see new video :)

Falk David (filedescriptor) changed the task status from Needs Triage to Confirmed.Mar 1 2021, 1:04 PM

I can confirm this on the latest 2.93.0 Alpha, branch: master, commit date: 2021-03-01 06:12, hash: rBbfc70a6a958b. This seems to be due to the modifier using the plane as the mirror object. I am not sure if this is intended or not. @Nathan Craddock (natecraddock) any ideas?

Yes, this is because pasting pulls in all dependencies (which is not a bug afaict).
It is the same for Ctrl+C, Ctrl+C in the viewport, so has nothing to do with the Outliner.

Philipp Oeser (lichtwerk) closed this task as Archived.Mar 1 2021, 1:55 PM

Think we have to close this, this is intended behavior (it ensures the pasted object will actually appear as expected -- and for this its dependencies are mandatory -- it is like appending in that regard).