Page MenuHome

"Subdivision Surface" node in "Geometry nodes" doesn't work in instaciated objects
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 970/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 460.79

Blender Version
Broken: version: 2.92.0, branch: master, commit date: 2021-02-24 16:25, hash: rB02948a2cab44

Short description of error
When working with the new "Geometry nodes" adding the "Subdivision Surface" doesn't affect any instanciated objects by "Point Instance" node. Its works just fine in the original mesh but not in the on the added with "Point Instance" node. Works also with objects added with "Object Info" node. Just found out the "Triangulate" shares the same problem.

Exact steps for others to reproduce the error
Attached file has all setup to find the problem.

  1. Add a plane object along with the default cube;
  2. Divide the viewport and change one to "Geometry Node Editor";
  3. Select the plane and click "New" in geometry node in order the create a new node tree;
  4. After "Group Input" add a "Point Distribute", after that add a "Point Instance" node, after that a "Subdivision Surface node";
  5. In "Point Instance" on "Object:" parameter choose the default "Cube".
  6. As you can see the Subdivison doesn't do anything doesn't matter the Level of subdivision chosed.

The problem is the same with or without the "Point distribute" node.

Event Timeline

Falk David (filedescriptor) changed the task status from Needs Triage to Confirmed.Mar 1 2021, 9:27 AM

This is confirmed for the 2.92.0 release, but it works in master. @Hans Goudey (HooglyBoogly) Is there any particular commit that could be added to T85958 ? Or is this a limitation for 2.92 ?

Hans Goudey (HooglyBoogly) closed this task as Archived.Mar 1 2021, 4:02 PM

Yeah, that's how geometry nodes works in 2.92. Instances are just final instances, and the only way to make them real is with the "Make Instances Real" operator.

Thanks for the report anyway @Samuel Santos (samuelsantos)