Page MenuHome

Segmentation fault when saving system-info.txt (linux/amd)
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.11.2-arch1-1-x86_64-with-arch 64 Bits
Graphics card: AMD Radeon RX 5700 XT (NAVI10, DRM 3.40.0, 5.11.2-arch1-1, LLVM 13.0.0) AMD 4.6 (Core Profile) Mesa 21.1.0-devel (git-f67259d83b)

Blender Version
Broken: version: 2.92.0, branch: master, commit date: 2021-02-24 16:25, hash: rB02948a2cab44
Worked: Unknown

Short description of error
When saving system-info.txt, the program produces a segfault.

Exact steps for others to reproduce the error

  1. Open Blender and select "General" under "New File".
  2. [Help] > [Save System Info]
  3. Save the file on your desktop.

Logs



Event Timeline

I cannot reproduce this with a GeForce GTX 1060 6GB. The next line in the system-info-crash.txt should be GL_ARB_vertex_buffer_object so presumably, that's where it crashed.

This issue and T86166 may be related. It may be related to the amd drivers, but I'm not sure. If nvidia works, amd might not.

I uninstalled everything related to OpenCL and it made this crash stop happening. I'll attach a full system-info.txt just in case it helps at all.

Philipp Oeser (lichtwerk) closed this task as Resolved.Mar 17 2021, 3:28 PM
Philipp Oeser (lichtwerk) claimed this task.

I uninstalled everything related to OpenCL and it made this crash stop happening

Thx getting back.
Since this seems to be an issue isolated to your system, and you've found a way to work around it, I think it is reasonable to close this as resolved.
It is still useful information (the fact that uninstalling OpenCL solved this), so thx for this.