Page MenuHome

i can't import fbx because of python:Traceback
Closed, ResolvedPublic

Description

i can't import fbx.
and errors shows up

Python: Traceback (most recent call last):

File "C:\Users\User\Downloads\blender-2.92.0-windows64\2.92\scripts\addons\io_scene_fbx\__init__.py", line 216, in execute
  if import_fbx.load(self, context, filepath=path, **keywords) == {'FINISHED'}:
File "C:\Users\User\Downloads\blender-2.92.0-windows64\2.92\scripts\addons\io_scene_fbx\import_fbx.py", line 2613, in load
  _(); del _
File "C:\Users\User\Downloads\blender-2.92.0-windows64\2.92\scripts\addons\io_scene_fbx\import_fbx.py", line 2612, in _
  fbx_item[1] = blen_read_material(fbx_tmpl, fbx_obj, settings)
File "C:\Users\User\Downloads\blender-2.92.0-windows64\2.92\scripts\addons\io_scene_fbx\import_fbx.py", line 1473, in blen_read_material
  blen_read_custom_properties(fbx_obj, ma, settings)
File "C:\Users\User\Downloads\blender-2.92.0-windows64\2.92\scripts\addons\io_scene_fbx\import_fbx.py", line 372, in blen_read_custom_properties
  assert(val >= 0 and val < len(enum_items))

AssertionError

location: <unknown location>:-1

Event Timeline

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Mar 16 2021, 11:26 AM

I assume this might be a duplicate of T81657: FBX Import error (enum with -1 value -- e.g. as done by the babylonjs exporter from 3dsmax).

Are you exporting from 3dsmax and have the babylonjs exporter installed?
If not, please share the FBX that causes this issue when importing.

Sorry for no reply since long time .
Yes,I exporting from 3dsmax and have the babylonjs exporter installed.
Seems it the problem,so I uninstalled the babylonjs exporter and reinstall the 3ds max.
And problem solved.
Thank for reply me!

Philipp Oeser (lichtwerk) closed this task as Resolved.Sat, Mar 27, 9:09 AM
Philipp Oeser (lichtwerk) claimed this task.

OK, thx getting back, will close then