Page MenuHome

Help Tutorials opens invalid web page (error 404)
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.8.0-45-generic-x86_64-with-glibc2.31 64 Bits
Graphics card: GeForce GTX 660/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 460.56
Browser: Google Chrome Version 89.0.4389.90 (Official Build) (64-bit)

Blender Version
Broken: version: 2.93.0 Alpha, branch: master, commit date: 2021-03-17 23:14, hash: rB30b5fd1a3cd5
Worked: unknown, but does currently even not work using 2.83.9.

Short description of error
When clicking on Help followed by Tutorials on the top main menus a link to https://www.blender.org/tutorials is opened in the browser with an error 404.

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue]
[Based on the default startup or an attached .blend file (as simple as possible)]
Start Blender and click Help then Tutorials in the dialog box.

Note: a potentially correct link is https://www.blender.org/support/tutorials/. Maybe the simplest way to solve the problem is to implement an appropriate redirect on the website.

Event Timeline

Evan Wilson (EAW) changed the task status from Needs Triage to Confirmed.Thu, Mar 18, 3:24 PM

I checked a January archive page, which used to redirect to appropriate site. http://web.archive.org/web/20210126181616/https://www.blender.org/tutorials
So this seems to be a effect of the recent Incident. So changing tags.

I’ll also submit a patch update the topbar.py script in Blender to point to the correct url.

Dan McGrath (dmcgrath) closed this task as Resolved.Thu, Mar 18, 5:43 PM
Dan McGrath (dmcgrath) claimed this task.

A redirect was added to map /tutorials to /support/tutorials. Thanks for the report!