Page MenuHome

Geometry nodes do not show wireframe instances in solid mode
Confirmed, NormalPublicBUG

Description

System Information
Operating system: Windows-8.1-6.3.9600-SP0 64 Bits
Graphics card: GeForce GTX 660 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 461.40

Blender Version
Broken: version: 2.93.0 Alpha, branch: master, commit date: 2021-03-18 21:29, hash: rB36deb8a48ef2

Short description of error
If I instance wireframe (only edges) object with GN, I don`t see instances in Solid mode (except 1st).
Wireframe mode is okay.


Event Timeline

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Confirmed.Mon, Mar 22, 9:22 PM
Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Bug".
Germano Cavalcante (mano-wii) edited projects, added Nodes & Physics; removed Nodes.

I can confirm.
If you add any other modifier (like the array), the wireframe appears proving that it is wire geometry.

@Germano Cavalcante (mano-wii) next modifier converting instances to unite geometry, that is why it become visible again

It is happening if the mesh contains only edges.
E.g
Replacing the Line Primitive with Circle in the blend file of T86828, we observe the same behavior.
Change the "Fill type" of Circle to Ngon or triangle, the mesh appears.

Vyacheslav (hitrpr) added a comment.EditedFri, Apr 2, 5:39 PM

@Himanshi Kalra (calra) exactly!
It is only about edge appearance from solid. And another special case. So it looks like object with GN inherits main mode (solid) and ignores wire mode for case with wire only.