Page MenuHome

VSE: Crash When Trying to add Image Sequence / Movie [if based on file opened from pre 2.8]
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-4.15.0-140-generic-x86_64-with-glibc2.23 64 Bits
Graphics card: GeForce GTX 1070 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 460.39

Blender Version
Broken: version: 2.93.0 Alpha (and 2.92.0), branch: master, commit date: 2021-03-28 10:50, hash: rBe47f5cf1979d
Worked: 2.91.2

Caused by rB571362642201

Short description of error
Adding an Image/Sequence in the video sequence editor crashes blender

Exact steps for others to reproduce the error
Further investigation reveals that .blend files created with versions prior to 2.8, which used the Factory Default Startup file, are affected.

To reproduce :

  1. Start blender 2.79b
  1. Click 'File | Load Factory Settings'
  1. Save the file.
  1. Start blender 2.92.0 or later.
  1. Open the file saved in step 3.
  1. Switch to the VSE and click 'Add | Image/Sequence'

Event Timeline

Falk David (filedescriptor) changed the task status from Needs Triage to Needs Information from User.Mar 29 2021, 12:37 PM

Please open Blender's installation directory and double click on the blender_debug_gpu.cmd. This will start Blender in debug mode and create log files. Try to make Blender crash again. Once it crashes the Windows Explorer should open and show you up to two files, a debug log and the system information. Add them to your bug report via drag and drop. Please also upload the crash log located in C:\Users\[your username]\AppData\Local\Temp\[project name].crash.txt (or simply type %TEMP% into the path bar of the Windows Explorer).

Cannot reproduce here.

I can't find anything remotely similar to 'blender_debug_gpu.cmd' in my blender installation - I'm running on a Linux system.

I ran blender from the command-line with the options :

--debug-all --log-level 100 --verbose

After a lot of event messages I did Add | Image/Sequence and got a the message :

Writing: /tmp/blender.crash.txt
Segmentation fault (core dumped)

Falk David (filedescriptor) changed the task status from Needs Information from User to Needs Triage.Mar 29 2021, 1:23 PM

Philipp,

It happens as soon as I click Add | Image/Sequence

I don't get any dialogue box to select images so it's not a problem with specific images.

It happens on 2.92.0 but 2.83.13 works fine. I'll install other versions and let you know when the problem started.

Philipp,

The problem does not occur in version 2.91.2.

Also, the problem occurs when I do Add | Movie, but not when I do Add | Sound.

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Mar 29 2021, 2:55 PM

Maybe it would be good to share/upload one movie that causes issues here (or are you saying this happens with any movie?)

Philipp,

As soon as I click either 'Movie' or 'Image/Sequence' from the 'Add' menu, blender crashes.

I don't get the chance to specify a movie or image/sequence, no file view window appears.

Selecting 'Sound' from the 'Add' menu brings up a file view window as expected.

@Terry Edhouse (MrTez) So the file dialog does not open and Blender crashes before? What happens when you open any other file dialog?

I've only had it crash in the Video Sequencer when clicking either 'Movie' or 'Image/Sequence' from the 'Add' menu - selecting 'Sound' from the 'Add' menu brings up a file view window as expected. Hasn't crashed on anything else.

Falk David (filedescriptor) changed the task status from Needs Information from User to Needs Triage.Apr 2 2021, 5:43 PM
Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Apr 9 2021, 10:42 AM

There were a couple of reports in relation of the filebrowser used in the VSE, e.g. T85911: Adding video or audio to VSE Sequencer crashes Blender

Not exactly sure where the roots are, but since Factory setting resolved in T85911, please try that as well:
Please try with File → Defaults → Load Factory Settings to see if you still can reproduce this issue.

Philipp Oeser (lichtwerk) renamed this task from Video Sequence editor causes crash to VSE: Crash When Trying to add Image Sequence / Movie.Apr 9 2021, 10:43 AM

I've tried File → Defaults → Load Factory Settings and it works.

I had previously tried 'Load Factory Preferences' but that didn't prevent the crash.

Philipp Oeser (lichtwerk) closed this task as Resolved.Apr 9 2021, 11:15 AM
Philipp Oeser (lichtwerk) claimed this task.

OK, thx getting back!

So this might be an Addon interfering here?
(could also be a Preference - though i doubt that - or something in your startup file?)

You could try enabling Addons one by one and check where other preferences differ.
For now, I will close this as resolved, but please keep us up-to-date if you've found which is the cause on you side (we can always reopen in such case).

I narrowed down the problem to something in my startup.blend file. Disabling all AddOns made no difference.

Further investigation reveals that .blend files created with versions prior to 2.8, which used the Factory Default Startup file, are affected.

To reproduce :

  1. Start blender 2.79b
  1. Click 'File | Load Factory Settings'
  1. Save the file.
  1. Start blender 2.92.0 or later.
  1. Open the file saved in step 3.
  1. Switch to the VSE and click 'Add | Image/Sequence'

I've discovered this problem even occurs with .blend files created by other people that I've downloaded (but not modified) - the version string at the start of the files I tested was v257.

Doing the above using blender 2.82.7 or 2.83.13 in step 1 does not result in a crash.

The weird thing is that while using the 2.79b default startup file causes the crash, if I use my customised 2.79b startup.blend file (ie., I skip step 2 above) there is no crash.

I've attached a copy of the .blend file I saved in step 3 above.

Philipp Oeser (lichtwerk) reopened this task as Confirmed.Apr 16 2021, 4:14 PM
Philipp Oeser (lichtwerk) triaged this task as High priority.

Yep, can repro now, nice find.

This is caused by rB571362642201: VSE: Improve motion-picture workflow, fix incoming...

Philipp Oeser (lichtwerk) renamed this task from VSE: Crash When Trying to add Image Sequence / Movie to VSE: Crash When Trying to add Image Sequence / Movie [if based on file opened from pre 2.8].Apr 16 2021, 4:16 PM
Philipp Oeser (lichtwerk) updated the task description. (Show Details)
Philipp Oeser (lichtwerk) updated the task description. (Show Details)