Page MenuHome

Grease Pencil edit mode missing vertex
Closed, ArchivedPublic

Description

System Information
Operating system:windows 10
Graphics card:GTX 1060

Blender Version
Broken:2.83/2.93

Exact steps for others to reproduce the error
GP In Edit mode, using the CTRL H shortcut, vertices will be hidden and unrecoverable. The same problem will occur with the new GP.

Rebooting the software, it’s still not working.

The only solution is to copy everything into the new project

Event Timeline

Falk David (filedescriptor) changed the task status from Needs Triage to Confirmed.Apr 1 2021, 8:39 AM
Falk David (filedescriptor) changed the subtype of this task from "Report" to "To Do".

With Ctrl+H you turn down the vertex opacity to 0. You can turn it back up to 1 in the Overlay Settings:

But you are right in that the shortcut should probably be a toggle or there should be a shortcut to turn it back to 1. Will mark this as a To Do.

raylee (raylee2233) closed this task as Resolved.Apr 1 2021, 8:39 AM
Falk David (filedescriptor) reopened this task as Confirmed.Apr 1 2021, 9:20 AM

No need to change the status to Resolved. I think the shortcut concern is valid and should be addressed.

Yes, the best is convert the operator to toggle. If > 0 then 0 and if 0 > 1

Falk David (filedescriptor) changed the task status from Confirmed to Needs Information from User.Apr 1 2021, 2:15 PM

I just tested this again and the toggle Ctrl+H does toggle the visibility for me in the latest 2.93 Alpha. @raylee (raylee2233) Could you make sure that the toggle is working for you? Pressing Ctrl+H should also reveal the points again.

I just checked and looked at the code and I can confirm it's already working as a toggle.

Falk David (filedescriptor) changed the subtype of this task from "To Do" to "Report".Apr 2 2021, 5:54 PM

It is indeed strange that Ctrl H sets the opacity of the overlay to 0.0 or 1.0 (like a toggle).
Users might expect two different shortcuts (Ctrl Alt H to 1.0 for example).

But is this operator really useful?

From what I can see in the comments, although strange that this is working as designed and there seems to be no plan or intention to change the behavior, so I will close the report.