Page MenuHome

Curve to Mesh Node
Closed, ResolvedPublicTO DO

Description

That screenshot is missing a "fill caps" option

This node takes a profile curve and extrudes it along each of the curve splines based on the data generated by the curve evaluation.

Details
  • Without a profile input, the node just uses a point, so it outputs a line.
  • The node uses the resolution, cyclic, and radius data already stored as attributes on the control points and on the spline.
  • The curve profile widget can be used as a node to provide a quick way to sketch a profile or choose from a preset.
  • For bezier splines, edges coming from sharp points on the profile can be automatically marked sharp.
  • By marking the ends sharp, the node can generate a fully manifold mesh.
Related Nodes
The node described in this task only does the "extrusion" type of meshing, a separate node would do the 2D meshing currently reserved for 2D curves.
With this node added, a simple further improvement would be to add a node that uses a separate profile for the start and end and smoothly interpolates between the two.
Further Questions
  • I would like to consider naming this node "Extrude Profile" or "Curve Extrude" since that's really what it's doing. There are many possible ways to convert a curve to a mesh, and this method is only one of them.
  • One conflict is exposing parameters in this node vs. storing them in the curve. For example, the normal calculation method currently at the top of the curve data property editor tab. I would like to store them in the curve, since the evaluated data can be used for much more than just this node.
Implementation
  • The mesh topology created will be quite similar to the grid node, the sphere node, and a cylinder with rings. That could be abstracted at some point.
  • Other than that, the actual creation of the mesh is rather simple, most of the complexity lies in the curve evaluation.

Event Timeline

Hans Goudey (HooglyBoogly) changed the task status from Needs Triage to Confirmed.Apr 12 2021, 3:37 PM
Hans Goudey (HooglyBoogly) created this task.

From the description it seems like it's planned that the extrusion part will be contained in this node, right?

Maybe the extrusion should be a separate node? The Curve to Mesh would then just output points connected by edges.

(Edit: Maybe I'm understanding this wrong and by extrusion you just mean extrusion along the tangent to the curve or something like that.)

Yes, I was thinking about that too, since the 2D meshing is also another way to do "Curve to Mesh", maybe this node could have a different name.

Dalai Felinto (dfelinto) closed this task as Resolved.May 25 2021, 2:12 PM