Page MenuHome

C drive gets filled while rendering still images
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce MX130/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 461.92

Blender Version
Broken: version: 2.92.0, branch: master, commit date: 2021-02-24 16:25, hash: rB02948a2cab44
Worked: (newest version of Blender that worked as expected)

Short description of error
Blender seems to fill the C drive with Gb of files after finishing rendering still images.

Please notice that the files could not be found even though the user searched through the hidden files in the drive.

Also it seems that the more complicated the scene is the more HDD memory it occupies.

Exact steps for others to reproduce the error
*Start the latest version of blender
*Create/Load a scene or object and render it
*Observe that the C drive has less space than it had before rendering the scene or the object.

Event Timeline

Falk David (filedescriptor) changed the task status from Needs Triage to Needs Information from User.EditedApr 26 2021, 7:16 PM

@Alex N. (Frizzy) Take a look at https://docs.blender.org/manual/en/latest/advanced/blender_directory_layout.html#temporary-directory. Blender probably uses the C:\tmp\ directory (or whatever TEMP points to). Could you check if you find any files in there?

I have already checked the TEMP folder in C and there's nothing there. Also all the temporary and cache folders in Blender settings are in my D drive. The issue still occurs.

@Alex N. (Frizzy) Ok. Could you try running blender using blender_debug_log.cmd from the blender installation folder? Just double-click on that file. This will start Blender in debug mode and create log files. Try reproducing the issue, then close Blender and it should create a log file. You can upload it here via drag & drop.

Well nothing can take up space on your hard drive without those consisting of files.

So it would certainly be a complaint if "Blender unnecessarily created these particular files in this specific location", but if you are unable to find such files you could just be seeing changes in Windows paging files. When you run any program that takes a lot of RAM your operating system might automatically transfer other programs from ram to a paging file. This is called Paging and the pagefile (hidden .sys files usually on your C drive) can be referred to as Virtual memory. That is just a natural part of any operating system usage.

@Alex N. (Frizzy) Ok. Could you try running blender using blender_debug_log.cmd from the blender installation folder? Just double-click on that file. This will start Blender in debug mode and create log files. Try reproducing the issue, then close Blender and it should create a log file. You can upload it here via drag & drop.

What I did was create a new scene, add a couple of objects and try to render it a few times. And it took 500 Mb just for one render of a simple static scene.

@Alex N. (Frizzy) - I have already checked the TEMP folder in C and there's nothing there. Also all the temporary and cache folders in Blender settings are in my D drive. The issue still occurs.

You have autosaves going here: C:\Users\Alex\AppData\Roaming\Blender Foundation\Blender\2.92\autosave
Thumbnails are being created (probably) here: C:\Users\Alex\.thumbnails\large
Your video driver is caching shaders on your C drive (somewhere) too.
Your operating system is making changes to pagefiles on C
"Steam", which you are running Blender from, could also be making changes.

Its just a bit hard to help with "some unnecessary files might be created on my C drive but I can't find them"

I understand that this issue is a far cry, I just wanted to make sure everything is alright with Blender and maybe help everyone out. I have checked the folders which you suggested and didn't find any big files.

I'll add this to the Unconfirmed tag, with the following meaning:

The issue reported can't be reproduced so far, and has been moved to the //BF Blender: Unconfirmed// project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.
Philipp Oeser (lichtwerk) closed this task as Archived.Fri, May 21, 1:53 PM

As per the tracker policy we assume the issue is gone and can be closed.

Thanks again for the report. If the problem persists please open a new report with the required information.