Page MenuHome

Attribute Remove Node Input Field Does Nothing
Closed, ResolvedPublic

Description

System Information
Operating system: Windows 10 (10.0.19042 Build 19042)
Graphics card: MSI GTX 1070Ti

Blender Version
Broken: 3.0.0 Alpha (I'm fairly certain this was also a problem in 2.93 beta builds)

Caused by rBb084b57fbf6d: Geometry Nodes: new geometry nodes evaluator

Short description of error
Apologies if this has been reported elsewhere, I couldn't find anything mentioning it. The Attribute Remove Node in Geometry Nodes has an input field that does not appear to do anything. Creating a String node with the name of the value removes it from the geometry as expected, while entering or auto-filling the value in the input field on the node itself does nothing.

Exact steps for others to reproduce the error

  1. Create a Geometry Node graph/group on any piece of geometry (default cube in the default startup file)
  2. Add an attribute to the geometry using Attribute Fill or some other method
  3. Place an Attribute Remove node after the Attribute Fill in the sequence

Event Timeline

Jonathan Gregory (RocketPunches) renamed this task from Attribute Remove Node Inpute Field Does Nothing to Attribute Remove Node Input Field Does Nothing.Tue, Jun 1, 4:27 PM
Jonathan Gregory (RocketPunches) updated the task description. (Show Details)
Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Confirmed.Tue, Jun 1, 4:59 PM
Philipp Oeser (lichtwerk) claimed this task.

Can confirm this working a couple of days, but is now broken again, will check.