Page MenuHome

Relocate broken file link doesn't restore armature poses.
Confirmed, NormalPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce GTX 1660 Ti with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 461.40

Blender Version
Broken: version: 2.92.0, branch: master, commit date: 2021-02-24 16:25, hash: rB02948a2cab44
Worked: (newest version of Blender that worked as expected)

note: the problem also exists in the 2.93 version, I was testing on both and submitted from the wrong window.

Short description of error
The 'Relocate' function to fix broken file links doesn't seem to restore armature poses.

Exact steps for others to reproduce the error

  • Make sure the prop.blend file is not located in the same directory as the scene.blend.
  • Open the scene.blend file, which uses a linked collection from the prop.blend file with a Library Override applied.
  • In the outliner in 'Blend File' mode, find the broken file link, right-click and select Relocate. Pick the prop.blend file.

The imported model seems to correctly restore the main armature transform, but not the pose or individual bone transforms. The original pose location
is marked with the 'marker' empty.

It's possible to manually restore poses saved in the pose library even after relocating, although that's not always practical.
Keyframing the bone transforms also seems to bypass the issue, however the timeline needs to be scrubbed before the restoration is applied.

Event Timeline

Antoine (pedrohoho) updated the task description. (Show Details)
Antoine (pedrohoho) updated the task description. (Show Details)
Antoine (pedrohoho) updated the task description. (Show Details)
Antoine (pedrohoho) updated the task description. (Show Details)
Richard Antalik (ISS) changed the task status from Needs Triage to Confirmed.Thu, Jun 10, 2:36 PM