Page MenuHome

Hook on curve glitch
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1080 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 466.47

Blender Version
Broken: version: 3.0.0 Alpha, branch: master, commit date: 2021-06-07 22:19, hash: rBef5a362a5b24

Short description of error
A hooked curve with bevel produces incorrect deformation

Exact steps for others to reproduce the error


Move the selected empty object
A glitch deformation will appear in the curve

Event Timeline

I can't reproduce that here, at least the file looks different for me and I don't have an artifact.

Linux, rB22ee056c3ab

You're right. It's not happening on Linux with a fresh build. Testing on Win again after the build bot decides to kick in. Probably some of the myriad curve commits in recent days

Pratik Borhade (PratikPB2123) changed the task status from Needs Triage to Confirmed.Wed, Jun 9, 7:50 AM

Yes yes, I can reproduce for recent 3.0.0 daily build (rBef5a362a5b24) on windows. Will bisect.

Yes yes, I can reproduce for recent 3.0.0 daily build (rBef5a362a5b24) on windows. Will bisect.

I'd wait for the next windows build bot and see if it's already fixed though

Pratik Borhade (PratikPB2123) changed the task status from Confirmed to Needs Information from User.Wed, Jun 9, 8:28 AM

No need to bisect (I guess)

@Daniel Salazar (zanqdo) , tested with recent commit (rB8c3f4f7edf9d9769f07291d64bc22fa85e210e86) and problem is not reproducible there. So I assume it is fixed.

check again with next build (when it updates).

Daily builds updated. @Daniel Salazar (zanqdo) can you check again with recent build?

To be clear, that commit only affects curves in geometry nodes. If this was broken briefly I'd assume it was due to one of my recent cleanup commits in displist.cc

Daniel Salazar (zanqdo) closed this task as Resolved.Wed, Jun 9, 7:16 PM
Daniel Salazar (zanqdo) claimed this task.

It's fixed now. Closing