Page MenuHome

Geometry Node "Attribute Transfer" UV Mapping problem
Confirmed, NormalPublic

Description

System Information
Operating system: Linux-4.15.0-147-generic-x86_64-with-glibc2.27 64 Bits
Graphics card: GeForce GTX 980/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 455.45.01

Blender Version
Broken: version: 3.0.0 Alpha, branch: master, commit date: 2021-07-03 15:41, hash: rBb73dc36859e0
Worked: (newest version of Blender that worked as expected)

Short description of error
Geometry Node "Attribute Transfer" do work with matérial node "UV Map" but does not with node "Texture Coordinates"

Exact steps for others to reproduce the error
Open the blend file and render in the viewport -> Result is OK
Change the texture uv input from node "UVMap" to UV from node "Texture Coordinates" -> Result is not OK anymore while should

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.Fri, Jul 9, 12:43 PM

Checked out with same build - rBb73dc36859e0 but I am not able to reproduce the problem

Is this what you meant? Can you share screenshot?

Yes it is what I mean. Your screenshot does show the cube WITHOUT the voronoi texture which is the problem.
While expected is as follows (with the voronoi texture as proof UV properly works with node "UV Map"):

Richard Antalik (ISS) changed the task status from Needs Information from User to Confirmed.Mon, Jul 12, 12:35 PM

Sorry I have missed effect of vornoi texture in setup, so I wasn't sure where to look for difference.

It's hard to see what is going on in this file exactly, can you provide a more simplified example that only contains the things necessary to reproduce the issue?
In any case, I believe this is a known issue and is related to T89054.