Page MenuHome

The spin deselects vertices and displays a non-selection error
Confirmed, NormalPublic

Description

System Information
Operating system: Windows 10
Graphics card: NVIDIA GeForce GTX 1080 Ti

Blender Version
Broken: version: 2.93.1, branch: master, commit date: 2021-06-22 05:57, hash: rB1b8d33b18c2f, type: release

Worked: version: 2.83.13, branch: master, commit date: 2021-03-09 07:21, hash: rBbb5004673085, type: Release

Short description of error
When using the spin button (menu on the right), the selected object is deselected and the spin does not work.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

  • Start Blender
  • Select the cube
  • Switch to edit mode
  • Move the selected cube up (Z)
  • Press the spin button (left)
  • Press "+"
  • The object deselects and the spin does not work

videos:

broken version:

working version:

Event Timeline

Pratik Borhade (PratikPB2123) closed this task as Archived.EditedSat, Jul 17, 11:27 AM

The object deselects and the spin does not work

Thanks for the report.

Single click with left mouse button on viewport will try to find the hit (to select the object element). Selected elements will reset the BM_ELEM_SELECT flag if no near hit is found.

Hold and drag is working in case of selected elements are not null. So I don't think this is a bug or regression.

I will close the report since working is same for versions 2.83 and above.

If problem is not fixed then please add a short video to describe the exact issue.

(Just my understanding from code, developers can correct if the explanation is wrong)

I'm sorry to show you a video. The spin does not work!
Watch the following video

On the previous version, it works!

Pratik Borhade (PratikPB2123) reopened this task as Confirmed.Sat, Jul 17, 3:03 PM

Can confirm now. Thank you for the video :)

[Guess I misunderstood the steps initially, my bad]