Page MenuHome

Asset Browser: Unable to use actions from "Animations" tab
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 462.59

Blender Version
Broken: version: 3.0.0 Alpha, branch: master, commit date: 2021-07-19 22:41, hash: rB24aae7ed63ab
Worked: never

Short description of error
When I try to save an animation in the "Animations" tab of Asset Browser, it saves, but I am unable to use it.
All options are greyed out.

Exact steps for others to reproduce the error

  1. Open Blender
  2. Create animated action
  3. Save action as an asset
  4. Double click to apply action asset - nothing happens

See video attached

Event Timeline

Richard Antalik (ISS) closed this task as Archived.Wed, Jul 21, 7:14 AM

From what I can see, grag and drop support for action ID type is not supported currently. Asset manager is still feature incomplete and in active development.

Closing, since this is TODO.

For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug

From what I can see, grag and drop support for action ID type is not supported currently. Asset manager is still feature incomplete and in active development.

Closing, since this is TODO.

For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug

The bug is not about drag and drop. It is about poses being created and saved instead of animations and inability to use animations from the "animations" tab
If this is a TODO, then there should be a task for it in a workboard, but I didn't find a single mention of it in a "Asset Browser" project, so I brought attention to this issue

Animation on object is not a pose though. The new pose library seems to be working correctly though.

Check release notes https://wiki.blender.org/wiki/Reference/Release_Notes/3.0/Animation_Rigging#Pose_Library
and https://code.blender.org/2021/05/pose-library-v2-0/