Page MenuHome

VSE: Handles covering ex. waveforms makes editing imprecise
Needs Information from Developers, NormalPublicDESIGN

Description

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce RTX 2060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 462.59

Blender Version
Broken: version: 2.93.0, branch: master, commit date: 2021-06-02 11:21, hash: rB84da05a8b806
Worked: (newest version of Blender that worked as expected)

Short description of error

Possible solution: make the handles bracket shaped, and to avoid bracket shaped handles to disappear among the outlines, then remove the outlines when a handle is selected. Related solution: https://developer.blender.org/D10297

Additional problem with unselected handle drawing: https://developer.blender.org/T90376

Event Timeline

Could the waveform be drawn over the handles? Or have the handles drawn with some level transparency?

The waveforms were drawn on top of the handles at some point and it looked like a bug.

As it is quite important that the selected elements are the most visible, making the handles more transparent, will mean that everything else will have to loose saturation, in order to keep the handle as the most visible elements.

What about a hybrid - draw the handles solid, draw the waveform, then draw the handle again with transparency over the waveform?

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from Developers.Aug 23 2021, 2:36 PM
Philipp Oeser (lichtwerk) changed the subtype of this task from "Report" to "Design".

Since this is more like an improvement -- also including some design work -- (as opposed to being a "real" bug), will set to TODO and let the module devs decide on this.

Peter Fog (tintwotin) closed this task as Archived.Oct 26 2021, 8:48 AM

As I do not have anymore time or motivation for a continued investment in the Blender project, I'm giving up on this report for now.

Philipp Oeser (lichtwerk) reopened this task as Needs Information from Developers.Oct 26 2021, 9:20 AM

Sorry to hear (thx again reporting). In my opinion we should not sweep this under the carpet (esp. since this already been confirmed), there is still a chance to get this fixed in the future and others might be affected by this issue as well.
Feel free to unsubscribe though.