Page MenuHome

Crash when exceeding memory_cache_limit in the viewport
Closed, ResolvedPublic

Description

System Information
Operating system: Linux-5.4.0-89-generic-x86_64-with-glibc2.31 64 Bits
Graphics card: GeForce GT 740M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 460.91.03

Blender Version
Broken: version: 3.0.0 Beta, branch: master, commit date: 2021-11-03 21:09, hash: rB3e6907eb8a3d
Worked: 2.93.4

Short description of error
Blender crashes when exceeding the memory_cache_limit value by having an image sequence drawn in the viewport, as an example as a background image or used as texture in a material.

Blender.crash for the builbot build of 3.0

I noticed that in my debug build the crash doesn't happen.
Ok, my debug build was simply outdated.
This is caused by b1bf8848895b, I haven't debugged farther but in this case it seems like item->c_handle is NULL in moviecache_valfree()

Exact steps for others to reproduce the error

  • open the default scene
  • change memory limit in the user preferences to some low value
  • drag and drop a movie file in the 3d viewport
  • fill the cache by changing the current frame

Event Timeline

This may also relate to T92740. I'll poke around tonight and see if I can get this bug to repro after my fix there.

Jesse Yurkovich (deadpin) closed this task as Resolved.Nov 5 2021, 5:03 AM
Jesse Yurkovich (deadpin) claimed this task.

This should now be fixed as well with the above commit. I was able to repro and then add in the additional guard.